summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-21 21:49:34 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-21 22:07:51 +0000
commita835ef1cbe547a66a7bced2f6d33d159b48cb893 (patch)
treea59655621e0e2d7f169a67b6b1e51b97dd9d91c5 /gnu/packages/python-science.scm
parent0c0c2d88150c8e42722cf91bd17d63ce71313c1f (diff)
gnu: python-mpl-scatter-density: Fix buld.
* gnu/packages/python-science.scm (python-mpl-scatter-density): [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ica320293019ae3e88e2b0654e356bc4d1be50626
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index d6d5b21609..8b461c5e4c 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -957,15 +957,17 @@ spheres, cubes, etc.")
(list
;; See <https://github.com/astrofrog/mpl-scatter-density/issues/42>.
#:test-flags #~(list "-k" "not test_default_dpi")))
- (propagated-inputs
- (list python-fast-histogram
- python-matplotlib
- python-numpy))
(native-inputs
(list python-pytest
python-pytest-cov
python-pytest-mpl
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-fast-histogram
+ python-matplotlib
+ python-numpy))
(home-page "https://github.com/astrofrog/mpl-scatter-density")
(synopsis "Matplotlib helpers to make density scatter plots")
(description