summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-07 10:07:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:05 +0000
commit8f178be63f415ec0bfa9716133f27b55091cea21 (patch)
tree4cb5e9837310d172f6270da207a5f162339db523 /gnu/packages/python-science.scm
parent973f8031224fde2ebbde1296b28c4fe4c8ba94ed (diff)
gnu: python-unyt: Adjust inputs.
* gnu/packages/python-science.scm (python-unyt): Shift the order of native and propagated inuts, add missing. [native-inputs]: Add python-setuptools-scm. Change-Id: Ibb1606be89743ac7d90fcafeaa75eae7ccfd756c
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 7b9d0cd7f6..63f11d9ca7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2178,18 +2178,20 @@ annotations on an existing boxplots and barplots generated by seaborn.")
(sha256
(base32 "00900bw24rxgcgwgxp9xlx0l5im96r1n5hn0r3mxvbdgc3lyyq48"))))
(build-system pyproject-build-system)
- ;; Astropy is an optional import, but we do not include it as it creates a
- ;; module cycle: astronomy->python-science->astronomy.
- (propagated-inputs (list python-h5py ; optional import
- python-matplotlib ; optional import
- python-numpy
- python-sympy))
;; Pint is optional, but we do not propagate it due to its size.
(native-inputs
(list python-pint
python-pytest
python-setuptools
+ python-setuptools-scm
python-wheel))
+ ;; Astropy is an optional import, but we do not include it as it creates a
+ ;; module cycle: astronomy->python-science->astronomy.
+ (propagated-inputs
+ (list python-h5py ; optional import
+ python-matplotlib ; optional import
+ python-numpy
+ python-sympy))
(home-page "https://unyt.readthedocs.io")
(synopsis "Library for working with data that has physical units")
(description