summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-21 21:42:49 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-21 22:07:51 +0000
commit0c0c2d88150c8e42722cf91bd17d63ce71313c1f (patch)
treeb3d4e2959902bce215b7be96d0bef6e3f708964b /gnu/packages/python-science.scm
parent4131737b550daa5abd667602295d209f946ae719 (diff)
gnu: python-supersmoother: Fix build
* gnu/packages/python-science.scm (python-supersmoother): [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: I33f151e74d54b6e0647b3cfae73c063522c35ea3
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 5ef91aaf11..d6d5b21609 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -3570,8 +3570,13 @@ proportional-integral-derivative} controller.")
(sha256
(base32 "1lkj8l2mpki6x2pxcwlrplx63lhi8h9v2rzxgjfb0cppsfr8m1wp"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-numpy))
- (native-inputs (list python-scipy))
+ (native-inputs
+ (list python-pytest
+ python-scipy
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-numpy))
(home-page "http://github.com/jakevdp/supersmoother")
(synopsis "Python implementation of Friedman's Supersmoother")
(description