summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/python-build.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 47c9c5a9ffe..d2368220075 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -219,7 +219,7 @@ Python file, so it can be easily copied into your project.")
(build-system pyproject-build-system)
(arguments (list #:build-backend "setuptools.build_meta"
#:tests? #f)) ;keep dependencies to a minimum
- (native-inputs (list python-wheel))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/pypa/trove-classifiers")
(synopsis "Canonical source for classifiers on PyPI")
(description "This package is the canonical source for classifiers use on
@@ -650,6 +650,7 @@ specified by PEP 517, @code{flit_core.buildapi}.")
;; builder instead.
#:build-backend "setuptools.build_meta"))
(propagated-inputs (list python-flit-core python-setuptools-scm python-tomli))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://gitlab.com/WillDaSilva/flit_scm")
(synopsis "PEP 518 build backend combining flit_core and setuptools_scm")
(description "This package provides a PEP 518 build backend that uses