summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-27 21:06:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:32 +0000
commit33210bced42287ae96b28b51fe22c2e4a2d7afa2 (patch)
tree021e29480a6f56d0bdcd7b6f3cab3cec9021aa1f /gnu/packages/python-build.scm
parent56cbfffc4ed3323f3e63ea5934d1383386845559 (diff)
gnu: python-packaging-bootstrap: Update to 23.2.
* gnu/packages/python-build.scm (python-packaging-bootstrap): Update to 23.2. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-flit-core. * gnu/packages/python-xyz.scm (python-packaging) [native-inputs]: Add python-flit-core. Change-Id: I5d3bdec62aabfe1b5e6de988d210862ad6da9002
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index e8cb8d02643..e18fe27fb1d 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -472,18 +472,20 @@ that client code uses to construct the grammar directly in Python code.")
(define-public python-packaging-bootstrap
(package
(name "python-packaging-bootstrap")
- (version "21.3")
+ (version "23.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "packaging" version))
(sha256
(base32
- "1sygirdrqgv4f1ckh9nhpcw1yfidrh3qjl86wq8vk6nq4wlw8iyx"))))
- (build-system python-build-system)
+ "1ifgjb0d0bnnm78hv3mnl7hi233m7jamb2plma752djh83lv13q4"))))
+ (build-system pyproject-build-system)
(arguments `(#:tests? #f)) ;disabled to avoid extra dependencies
(propagated-inputs
(list python-pyparsing python-six-bootstrap))
+ (native-inputs
+ (list python-flit-core))
(home-page "https://github.com/pypa/packaging")
(synopsis "Core utilities for Python packages")
(description "Packaging is a Python module for dealing with Python packages.