summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/protobuf.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 59f49c8cf4..11e81527e0 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -395,7 +395,9 @@ any memory-restricted system.")
(list python-grpc-stubs
python-grpcio-tools
python-pytest
- python-typing-extensions))
+ python-typing-extensions
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list protobuf
python-protobuf