summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-26 23:26:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:39 +0000
commitd9bbc3cabc87dac4f7530b8a03dd2a630086b169 (patch)
tree3184c27544b876d51adc9a1d45753772e28cc40d /gnu/packages/protobuf.scm
parent8808175fedd836eea006cf3861ec6c47a3250df2 (diff)
gnu: python-protobuf-5: Update to 5.28.3.
* gnu/packages/protobuf.scm (python-protobuf-5): Update to 5.28.3. [arguments]<phases>: Remove redundant custom 'check. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Icaa373287055ed4e170b5556f721018b910369c0
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm19
1 files changed, 6 insertions, 13 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 11e81527e0..d4b48e585b 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -441,28 +441,21 @@ from protobuf specification files.")
(define-public python-protobuf-5
(package
(name "python-protobuf")
- (version "5.27.3")
+ (version "5.28.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "protobuf" version))
(sha256
(base32
- "0b6qxb6hnhzmiz1wnjrjdmwxx2ddv9zr86p89vivgwj0wq1hjil2"))))
+ "0yzg3i40p7rbr51xr72avpvn72yin5xcxybkyc0y99c0j72dpfk4"))))
(build-system pyproject-build-system)
(arguments
(list
- ;; FIXME: ImportError: 'testing_refleaks' module incorrectly imported from
- ;; '/gnu/store/...-python-protobuf-5.27.3/lib/python3.10/site-packages/google/protobuf/internal'.
- ;; Expected '/tmp/guix-build-python-protobuf-5.27.3.drv-0/protobuf-5.27.3/google/protobuf/internal'.
- ;; Is this module globally installed?
- #:tests? #f
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "unittest" )))))))
+ #:tests? #f)) ; no tests provided for Python variant
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
(inputs (list protobuf))
(home-page "https://github.com/protocolbuffers/protobuf")
(synopsis "Protocol buffers is a data interchange format")