summaryrefslogtreecommitdiff
path: root/gnu/packages/potassco.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/potassco.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/potassco.scm')
-rw-r--r--gnu/packages/potassco.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index c5d00c9b1c..e08b478c22 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -589,7 +589,7 @@ are already predefined, but more can be added as logic programs.")
(setenv "CLORM_NOCLINGO" "1")
(delete-file "tests/test_mypy_query.py"))))))
(propagated-inputs (list python-clingo))
- (native-inputs (list python-typing-extensions))
+ (native-inputs (list python-typing-extensions python-setuptools python-wheel))
(home-page "https://potassco.org")
(synopsis "Object relational mapping to clingo")
(description "@acronym{Clorm, Clingo ORM} provides an @acronym{ORM,
@@ -651,6 +651,7 @@ the most probable model as well as finding all models and their probabilities.")
"1q6hlh4b5hsa4n5agvmfa9rhsxfd2g6kpl4b9kfccwbmf6dh51k6"))))
(build-system pyproject-build-system)
(propagated-inputs (list python-clingo))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://potassco.org/")
(synopsis "Solve dynamic temporal logic programs")
(description "This package provides a system to solve dynamic temporal
@@ -678,8 +679,10 @@ logic programs based on clingo.")
python-imageio
python-jinja2
python-jsonschema
- python-networkx))
- (native-inputs (list dot2tex graphviz python-pylint python-pytest))
+ python-networkx
+ python-setuptools))
+ (native-inputs (list dot2tex graphviz python-pylint python-pytest
+ python-wheel))
(home-page "https://github.com/potassco/clingraph")
(synopsis "Visualizer for graphs defined as logic programs")
(description