summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-web.scm
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:44 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:19:06 +0100
commite693b9c02a2d155028c8edb648b319dd73ded426 (patch)
tree2d0ab8dfe15cbb2e2c488edce8b35a70a0e939cb /gnu/packages/perl-web.scm
parent6af488be9a5dd8a60a15d6830d852555cda6f8c6 (diff)
gnu: Add perl-net-ip.
* gnu/packages/perl-web.scm (perl-net-ip): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages/perl-web.scm')
-rw-r--r--gnu/packages/perl-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index e4472beaeef..daaeed8de5a 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -313,3 +313,25 @@ by IP Address.")
over-SSL/STARTTLS support. This module inherits most of all the methods from
@code{Net::SMTP}(2.X).")
(license license:perl-license)))
+
+(define-public perl-net-ip
+ (package
+ (name "perl-net-ip")
+ (version "1.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MA/MANU/Net-IP-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ffn2xqqbkfi7v303sp5dwgbv36jah3vg8r4nxhxfiv60vric3q4"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Net-IP")
+ (synopsis "Perl extension for manipulating IPv4/IPv6 addresses")
+ (description
+ "This module provides functions to deal with IPv4/IPv6 addresses. The
+module can be used as a class, allowing the user to instantiate IP objects,
+which can be single IP addresses, prefixes, or ranges of addresses. There is
+also a procedural way of accessing most of the functions. Most subroutines can
+take either IPv4 or IPv6 addresses transparently.")
+ (license license:perl-license)))