summaryrefslogtreecommitdiff
path: root/gnu/packages/patool.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-31 12:48:06 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-12-31 13:30:38 +0300
commita37420aeb8b525b06d30411ae0b4c4ea49e0c37d (patch)
treecb8f516a75c952c9f00cbf107f74b1d18f7026fc /gnu/packages/patool.scm
parent7d7cdc3e4ee5b42c012dd5d4f5d799791304d01f (diff)
gnu: patool: Update to 3.1.0.
* gnu/packages/patool.scm (patool): Update to 3.1.0. [source]: Upstream changed the tag naming style since 2.4.0. Update the reference to the commit accordingly. [arguments]: Don't skip tests as they pass. Change-Id: Ia9944fb6418e83350d7d973f6e81670139beafb1 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/patool.scm')
-rw-r--r--gnu/packages/patool.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/patool.scm b/gnu/packages/patool.scm
index ccfbd11863d..1c265c9e798 100644
--- a/gnu/packages/patool.scm
+++ b/gnu/packages/patool.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,30 +38,18 @@
(define-public patool
(package
(name "patool")
- (version "2.1.1")
+ (version "3.1.0")
(source
(origin
(method git-fetch) ;no test data in PyPI archive
(uri (git-reference
(url "https://github.com/wummel/patool")
- (commit (string-append "upstream/" version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "09il0gq1xxlism30hx1aa06alz1xhrnhhwcjzx1znical0bp3q1r"))))
+ "1w20kiiq9ngy90lcgnjfjiwbp6zvf3vlhm34700ff8x85x9fknkr"))))
(build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- '(list "-k" (string-append
- ;; Disable failing tests.
- "not test_mime_file_compress"
- " and not test_mime_file_gzip"
- " and not test_mime_file_lzip"
- " and not test_bsdtar_gz_file"
- " and not test_py_tarfile_gz_file"
- " and not test_tar_gz_file"
- " and not test_tar_lzip_file"))))
(native-inputs
(list bzip2
cabextract