summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty10@gmail.com>2025-01-01 15:58:45 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2025-01-16 00:38:11 +0800
commiteb2092db0f22c56c347fca1eff07d1dd9fc2c441 (patch)
treee011a29e4ee59d020777cf4dbc7503b98269d79d /gnu/packages/patches
parentb696658ee8e0655b17f5d26e024956b5148e36d6 (diff)
gnu: Add corectrl.
* gnu/packages/admin.scm (corectrl): New variable. * gnu/packages/patches/corectrl-polkit-install-dir.patch: New file. * gnu/local.mk (dist_patch_DATA): Add reference to it. Change-Id: I7b0f85c917eb58d7518d7ee7c5b22ef2debde7d9
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/corectrl-polkit-install-dir.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/corectrl-polkit-install-dir.patch b/gnu/packages/patches/corectrl-polkit-install-dir.patch
new file mode 100644
index 0000000000..cced58996c
--- /dev/null
+++ b/gnu/packages/patches/corectrl-polkit-install-dir.patch
@@ -0,0 +1,23 @@
+See https://gitlab.com/corectrl/corectrl/-/issues/477
+
+diff --git a/src/helper/CMakeLists.txt b/src/helper/CMakeLists.txt
+index c262086..523ea97 100644
+--- a/src/helper/CMakeLists.txt
++++ b/src/helper/CMakeLists.txt
+@@ -26,15 +26,7 @@ message("D-Bus files will be installed into ${DBUS_DATADIR_PREFIX_DIR}/dbus-1")
+
+ # Find polkit
+ pkg_check_modules(POLKIT REQUIRED polkit-gobject-1)
+-execute_process(
+- COMMAND pkg-config --variable=policydir polkit-gobject-1
+- RESULT_VARIABLE POLKIT_POLICY_INSTALL_DIR_RESULT
+- OUTPUT_VARIABLE POLKIT_POLICY_INSTALL_DIR
+- OUTPUT_STRIP_TRAILING_WHITESPACE
+-)
+-if(NOT POLKIT_POLICY_INSTALL_DIR_RESULT EQUAL "0")
+- message(FATAL_ERROR "Failed to retrieve Polkit `policydir` variable using pkg-config")
+-endif()
++option(POLKIT_POLICY_INSTALL_DIR "Polkit policy directory")
+
+ list(APPEND HELPER_COMPILE_DEFINITIONS
+ SPDLOG_ACTIVE_LEVEL=SPDLOG_LEVEL_TRACE