summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorHomo <gay@disroot.org>2024-12-16 10:47:32 +0200
committerLudovic Courtès <ludo@gnu.org>2024-12-23 20:45:33 +0100
commitc302b7a5966908b3a5db1ef3ccd3af460b847675 (patch)
tree4bba8850fb9b833f77b91362d2e45ae080238553 /gnu/packages/patches
parent8636854d18d29f7638d5f55d1f7bd3c170585e70 (diff)
gnu: hugs: Fix build with GCC.
* gnu/packages/patches/hugs-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/hugs.scm (hugs)[source]: Use it. [native-inputs]: Remove. Change-Id: I8b17f6c8a89fbc25ac9fe40b58962c83b08cbc21 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/hugs-fix-build.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/hugs-fix-build.patch b/gnu/packages/patches/hugs-fix-build.patch
new file mode 100644
index 0000000000..2c053e18d0
--- /dev/null
+++ b/gnu/packages/patches/hugs-fix-build.patch
@@ -0,0 +1,24 @@
+Fixes build with GCC 5 and later.
+Patch from <https://aur.archlinux.org/cgit/aur.git/tree/hsbase_inline.patch?h=hugs>.
+
+diff --git a/packages/base/include/HsBase.h b/packages/base/include/HsBase.h
+index aa1a7fb..78d5b46 100644
+--- a/packages/base/include/HsBase.h
++++ b/packages/base/include/HsBase.h
+@@ -217,15 +217,7 @@ StgWord64 stg_integerToWord64 (StgInt sa, StgByteArray /* Really: mp_limb_t* */
+ when compiling to native code.
+ -------------------------------------------------------------------------- */
+
+-#ifndef INLINE
+-# if defined(_MSC_VER)
+-# define INLINE extern __inline
+-# elif defined(__GNUC__)
+-# define INLINE extern inline
+-# else
+-# define INLINE inline
+-# endif
+-#endif
++#define INLINE inline
+
+ INLINE int __hscore_get_errno(void) { return errno; }
+ INLINE void __hscore_set_errno(int e) { errno = e; }