summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2025-01-02 23:32:27 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-01-02 23:55:34 +0100
commita707ebe5d3875a49523bc17de2d36af6f1c18f7e (patch)
tree16ac1d925d332f00cdcd15117bac3745994d09a4 /gnu/packages/patches
parent5d7455bb580eed41a4fa7c20b71eaccad9f49e73 (diff)
gnu: whisper-cpp: Enable sdl2 and tests.
* gnu/packages/patches/whisper-cpp-enable-tests.patch: New file. * gnu/packages/machine-learning.scm (whisper-cpp)[source]: Add reference to patch. [arguments]<#:configure-flags>: Add configure flags. [arguments]<#:phases>: Disable big test on 32 bit. [inputs]: Add sdl2. [synopsis]: Modify. [description]: Modify. * gnu/local.mk (dist_PATCH_DATA): Register patch. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com> Change-Id: Icdb82c3c7d3d485346f89fe699d0d64b34c1b21a Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/whisper-cpp-enable-tests.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/whisper-cpp-enable-tests.patch b/gnu/packages/patches/whisper-cpp-enable-tests.patch
new file mode 100644
index 0000000000..c4340d4879
--- /dev/null
+++ b/gnu/packages/patches/whisper-cpp-enable-tests.patch
@@ -0,0 +1,19 @@
+Distribution specific patch
+
+restored tests commented out in CMakeLists.txt upstream
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c53252b..ee06015 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -176,8 +176,8 @@ install(FILES "${CMAKE_CURRENT_BINARY_DIR}/whisper.pc"
+ #
+
+ if (WHISPER_BUILD_TESTS AND NOT CMAKE_JS_VERSION)
+- #include(CTest)
+- #add_subdirectory(tests)
++ include(CTest)
++ add_subdirectory(tests)
+ endif ()
+
+ if (WHISPER_BUILD_EXAMPLES)