summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorunmush <unmush@hashbang.sh>2024-11-26 12:44:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-12-22 15:37:33 +0200
commit1b1e9917ad043ac279bd829cd8ac6a842667f648 (patch)
tree2d1352b87a75ef566387a9242907596d1d78cafc /gnu/packages/patches
parentf2098a776afff1deb23c5cbcd2c2d80278b9a208 (diff)
gnu: Add pnet-git.
* gnu/packages/dotnet.scm (pnet-git): New variable. * gnu/packages/patches/pnet-fix-line-number-info.patch, gnu/packages/patches/pnet-fix-off-by-one.patch, gnu/packages/patches/pnet-newer-libgc-fix.patch, gnu/packages/patches/pnet-newer-texinfo-fix.patch: New patches. * gnu/local.mk (dist_patch_DATA): Register new patches. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: Ic3e93dbaab24eb73fe9a35f711a710eed6a823a1
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/pnet-fix-line-number-info.patch13
-rw-r--r--gnu/packages/patches/pnet-fix-off-by-one.patch13
-rw-r--r--gnu/packages/patches/pnet-newer-libgc-fix.patch45
-rw-r--r--gnu/packages/patches/pnet-newer-texinfo-fix.patch13
4 files changed, 84 insertions, 0 deletions
diff --git a/gnu/packages/patches/pnet-fix-line-number-info.patch b/gnu/packages/patches/pnet-fix-line-number-info.patch
new file mode 100644
index 0000000000..9e5af84941
--- /dev/null
+++ b/gnu/packages/patches/pnet-fix-line-number-info.patch
@@ -0,0 +1,13 @@
+diff --git a/codegen/cg_coerce.c b/codegen/cg_coerce.c
+index 92d2f59a..c90ad5e2 100644
+--- a/codegen/cg_coerce.c
++++ b/codegen/cg_coerce.c
+@@ -1203,6 +1203,8 @@ int ILCoerce(ILGenInfo *info, ILNode *node, ILNode **parent,
+ != ILMachineType_Void)
+ {
+ *parent = ILNode_CastSimple_create(node, constType);
++ yysetfilename(*parent, yygetfilename(node));
++ yysetlinenum(*parent, yygetlinenum(node));
+ return 1;
+ }
+ else if(indirect && GetIndirectConvertRules(info,fromType,toType,0,
diff --git a/gnu/packages/patches/pnet-fix-off-by-one.patch b/gnu/packages/patches/pnet-fix-off-by-one.patch
new file mode 100644
index 0000000000..858d226697
--- /dev/null
+++ b/gnu/packages/patches/pnet-fix-off-by-one.patch
@@ -0,0 +1,13 @@
+diff --git a/codegen/cg_genattr.c b/codegen/cg_genattr.c
+index 535852da..c3acc0dc 100644
+--- a/codegen/cg_genattr.c
++++ b/codegen/cg_genattr.c
+@@ -1532,7 +1532,7 @@ static int MarshalAsAttribute(ILGenInfo *info,
+ else
+ {
+ sizeParamIndex = attributeInfo->namedArgs[currentNamedArg].evalValue.un.i4Value;
+- if(sizeParamIndex <= 0)
++ if(sizeParamIndex < 0)
+ {
+ CGErrorForNode(info, attributeInfo->namedArgs[currentNamedArg].node,
+ _("The size parameter index must be >= 0"));
diff --git a/gnu/packages/patches/pnet-newer-libgc-fix.patch b/gnu/packages/patches/pnet-newer-libgc-fix.patch
new file mode 100644
index 0000000000..1084b5a5be
--- /dev/null
+++ b/gnu/packages/patches/pnet-newer-libgc-fix.patch
@@ -0,0 +1,45 @@
+diff --git a/support/hb_gc.c b/support/hb_gc.c
+index a5addb2d..41126963 100644
+--- a/support/hb_gc.c
++++ b/support/hb_gc.c
+@@ -104,12 +104,6 @@ static volatile int _FinalizersRunningSynchronously = 0;
+ #define GC_TRACE(a, b)
+ #endif
+
+-/*
+- * This is a internal global variable with the number of reclaimed bytes
+- * after a garbage collection.
+- */
+-extern GC_signed_word GC_bytes_found;
+-
+ /*
+ * Main entry point for the finalizer thread.
+ */
+@@ -432,6 +426,7 @@ int ILGCFullCollection(int timeout)
+ {
+ int lastFinalizingCount;
+ int hasThreads;
++ struct GC_prof_stats_s stats;
+
+ hasThreads = _ILHasThreads();
+
+@@ -462,7 +457,8 @@ int ILGCFullCollection(int timeout)
+ GC_TRACE("Last finalizingCount = %i\n", lastFinalizingCount);
+
+ GC_gcollect();
+- bytesCollected = GC_bytes_found;
++ GC_get_prof_stats(&stats, sizeof(stats));
++ bytesCollected = stats.bytes_reclaimed_since_gc;
+
+ GC_TRACE("GC: bytes collected = %i\n", bytesCollected);
+
+@@ -516,7 +512,8 @@ int ILGCFullCollection(int timeout)
+ GC_TRACE("Last finalizingCount = %i\n", lastFinalizingCount);
+
+ GC_gcollect();
+- bytesCollected = GC_bytes_found;
++ GC_get_prof_stats(&stats, sizeof(stats));
++ bytesCollected = stats.bytes_reclaimed_since_gc;
+
+ GC_TRACE("GC: bytes collected = %i\n", bytesCollected);
+
diff --git a/gnu/packages/patches/pnet-newer-texinfo-fix.patch b/gnu/packages/patches/pnet-newer-texinfo-fix.patch
new file mode 100644
index 0000000000..b57052eeea
--- /dev/null
+++ b/gnu/packages/patches/pnet-newer-texinfo-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/doc/pnettools.texi b/doc/pnettools.texi
+index 916d90bb..cdbe05cf 100644
+--- a/doc/pnettools.texi
++++ b/doc/pnettools.texi
+@@ -59,7 +59,7 @@ Copyright @copyright{} 2001, 2002, 2003 Southern Storm Software, Pty Ltd
+ @center @titlefont{Portable.NET Development Tools}
+
+ @vskip 0pt plus 1fill
+-@center{Copyright @copyright{} 2001, 2002, 2003 Southern Storm Software, Pty Ltd}
++@center Copyright @copyright{} 2001, 2002, 2003 Southern Storm Software, Pty Ltd
+ @end titlepage
+
+ @c -----------------------------------------------------------------------