summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-24 00:35:38 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-24 00:37:54 +0100
commit0aeb38eac6f0e8ab22d34faf4dae275f17a5fea1 (patch)
treec81fc42413062e9955bd89787d37fb015e657266 /gnu/packages/patches
parent84e5c2dd4ac11c9fea4c1ae1c755bf86322d5953 (diff)
gnu: Add modglue.
* gnu/packages/patches/modglue-fix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Add reference to it. * gnu/packages/engineering.scm (modglue): New variable. Change-Id: I3ffe9e8b258f49021a21b17f088bebb44245cbad
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/modglue-fix-build.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/modglue-fix-build.patch b/gnu/packages/patches/modglue-fix-build.patch
new file mode 100644
index 0000000000..76b533b75f
--- /dev/null
+++ b/gnu/packages/patches/modglue-fix-build.patch
@@ -0,0 +1,17 @@
+Author: Danny Milosavljevic <dannym+c@friendly-machines.com>
+Date: 23 Dec 2024
+License: GPL2+
+
+diff -ru orig/l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc
+--- orig/l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc 2024-12-23 20:23:47.132475052 +0100
++++ l34h8423ap03vfm6xj8lby3363vgbg5l-modglue-1.20-checkout/src/pipe.cc 2024-12-23 20:24:08.028172621 +0100
+@@ -241,8 +241,8 @@
+ struct iovec iov[1];
+ struct msghdr msg;
+ struct {
+- struct cmsghdr cm;
+ int fd;
++ struct cmsghdr cm;
+ } cmsg;
+
+ memset( &msg, 0, sizeof(msg) );