summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-30 16:02:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:21:29 +0200
commit0317ddea5e86edb4a5dfb6c2cdb18a41e32cb711 (patch)
tree7a43c9806ef039a182392cfa2ff724ef9b6c28e7 /gnu/packages/patches
parentacb11250dd51110227df89f67ec425b7c22b6ccf (diff)
gnu: maturin: Update to 1.8.0.
* gnu/packages/rust-apps.scm (maturin): Update to 1.8.0. [source]: Remove snippet. [arguments]: Don't run the tests in release mode. Adjust the custom 'install-completions phase to install the bash completions in the correct directory and to install the nushell completions. [cargo-inputs]: Add rust-pretty-assertions-1, rust-same-file-1, rust-schemars-0.8, rust-xid-unicode-0.2. Replace rust-cargo-metadata-0.18 with 0.19, rust-cbindgen-0.26 with 0.27, rust-clap-complete-command-0.5 with 0.6, rust-fs-err-2 with 3, rust-goblin-0.7 with 0.9, rust-minijinja-1 with 2, rust-pep440-rs-0.3 with 0.6, rust-pep508-0.2 with 0.6, rust-pyproject-toml-0.8 with 0.11, rust-rustls-0.21 with 0.23, rust-target-lexicon-0.12 with 0.13, rust-thiserror-1 with 2, rust-toml-edit-0.21 with 0.22, rust-zip-0.6 with 2. [cargo-development-inputs]: Add rust-fs4-0.12, rust-rstest-0.22. Replace rust-trycmd-0.14 with 0.15, rust-which-5 with 7. * gnu/packages/patches/maturin-no-cross-compile.patch: Update patch. Change-Id: Iad445c26556efe4527085876a759d65d4f72621d
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/maturin-no-cross-compile.patch32
1 files changed, 21 insertions, 11 deletions
diff --git a/gnu/packages/patches/maturin-no-cross-compile.patch b/gnu/packages/patches/maturin-no-cross-compile.patch
index 98af33d3c7..d391d4028c 100644
--- a/gnu/packages/patches/maturin-no-cross-compile.patch
+++ b/gnu/packages/patches/maturin-no-cross-compile.patch
@@ -2,36 +2,46 @@ Remove dependencies on xwin and zig. We're not offering cross-compilation
options using these crates.
diff --git a/Cargo.toml b/Cargo.toml
-index 6704e46..ff126a9 100644
+index 24305db..c7641f9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -83,16 +83,6 @@ version = "0.1.16"
+@@ -95,16 +95,6 @@ version = "0.1.24"
[dependencies.cargo-options]
version = "0.7.2"
-[dependencies.cargo-xwin]
--version = "0.16.2"
+-version = "0.18.3"
-optional = true
-default-features = false
-
-[dependencies.cargo-zigbuild]
--version = "0.18.0"
+-version = "0.19.7"
-optional = true
-default-features = false
-
[dependencies.cargo_metadata]
- version = "0.18.0"
+ version = "0.19.0"
+
+@@ -364,10 +354,6 @@ version = "7.0.0"
-@@ -321,8 +311,6 @@ version = "5.0.0"
[features]
cli-completion = ["dep:clap_complete_command"]
- cross-compile = [
+-cross-compile = [
- "zig",
- "xwin",
- ]
+-]
default = [
"full",
-@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
+ "rustls",
+@@ -375,7 +361,6 @@ default = [
+ faster-tests = []
+ full = [
+ "cli-completion",
+- "cross-compile",
+ "scaffolding",
+ "upload",
+ ]
+@@ -384,7 +369,6 @@ log = []
native-tls = [
"dep:native-tls",
"ureq?/native-tls",
@@ -39,7 +49,7 @@ index 6704e46..ff126a9 100644
"dep:rustls-pemfile",
]
password-storage = [
-@@ -351,7 +338,6 @@ password-storage = [
+@@ -394,7 +378,6 @@ password-storage = [
rustls = [
"dep:rustls",
"ureq?/tls",
@@ -47,7 +57,7 @@ index 6704e46..ff126a9 100644
"dep:rustls-pemfile",
]
scaffolding = [
-@@ -369,5 +355,3 @@ upload = [
+@@ -416,5 +399,3 @@ upload = [
"wild",
"dep:dirs",
]