summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-12 09:14:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-12 11:26:05 +0300
commitb555d987b9b89a694bd1f412a5d40d3b73b144ba (patch)
tree71a86547af435b92a5d69d078da128f966905733 /gnu/packages/patches
parent73158a5f6299a07a1581f0f33c5e86be660f6270 (diff)
gnu: python-pygpgme: Update to 0.4.
* gnu/packages/gnupg.scm (python-pygpgme): Update to 0.4. [source]: Remove patches. [build-system]: Switch to the pyproject build system. [arguments]: Remove custom phases. [native-inputs]: Remove gnupg-1. Add gnupg. [home-page]: Update home-page. * gnu/packages/patches/pygpgme-disable-problematic-tests.patch, gnu/packages/patches/python-pygpgme-fix-pinentry-tests.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove patches. Change-Id: I0986e0f87a1b824bce5cc24f34467132d14296e4
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/pygpgme-disable-problematic-tests.patch37
-rw-r--r--gnu/packages/patches/python-pygpgme-fix-pinentry-tests.patch69
2 files changed, 0 insertions, 106 deletions
diff --git a/gnu/packages/patches/pygpgme-disable-problematic-tests.patch b/gnu/packages/patches/pygpgme-disable-problematic-tests.patch
deleted file mode 100644
index 2129d2f973..0000000000
--- a/gnu/packages/patches/pygpgme-disable-problematic-tests.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-These tests require a gpg agent to run, and are difficult to get to work right
-in Guix's environment. For more details, see:
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713074
- https://bugs.launchpad.net/pygpgme/+bug/999949
-
---- pygpgme-0.3/tests/test_encrypt_decrypt.py 2012-02-28 19:10:28.000000000 -0800
-+++ pygpgme-0.3/tests/test_encrypt_decrypt.py 2016-02-05 10:21:58.966685384 -0800
-@@ -125,7 +125,7 @@
- ctx.decrypt(ciphertext, plaintext)
- self.assertEqual(plaintext.getvalue(), b'Hello World\n')
-
-- def test_encrypt_symmetric(self):
-+ def skip_test_encrypt_symmetric(self):
- plaintext = BytesIO(b'Hello World\n')
- ciphertext = BytesIO()
- def passphrase(uid_hint, passphrase_info, prev_was_bad, fd):
-
---- pygpgme-0.3/tests/test_passphrase.py 2012-02-28 19:04:17.000000000 -0800
-+++ pygpgme-0.3/tests/test_passphrase.py 2016-02-05 10:21:47.990630956 -0800
-@@ -30,7 +30,7 @@
-
- import_keys = ['passphrase.pub', 'passphrase.sec']
-
-- def test_sign_without_passphrase_cb(self):
-+ def skip_test_sign_without_passphrase_cb(self):
- ctx = gpgme.Context()
- key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
- ctx.signers = [key]
-@@ -51,7 +51,7 @@
- self.prev_was_bad = prev_was_bad
- os.write(fd, b'test\n')
-
-- def test_sign_with_passphrase_cb(self):
-+ def skip_test_sign_with_passphrase_cb(self):
- ctx = gpgme.Context()
- key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
- ctx.signers = [key]
diff --git a/gnu/packages/patches/python-pygpgme-fix-pinentry-tests.patch b/gnu/packages/patches/python-pygpgme-fix-pinentry-tests.patch
deleted file mode 100644
index 1f7a4cadb7..0000000000
--- a/gnu/packages/patches/python-pygpgme-fix-pinentry-tests.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-Fix test failure of test_XXX caused by upgrade of gpgme from 1.6.0 to
-1.8.0:
-
-======================================================================
-FAIL: test_encrypt_to_signonly (tests.test_encrypt_decrypt.EncryptDecryptTestCase)
-----------------------------------------------------------------------
-Traceback (most recent call last):
- File "/tmp/guix-build-python2-pygpgme-0.3.drv-0/pygpgme-0.3/tests/test_encrypt_decrypt.py", line 185, in test_encrypt_to_signonly
- self.assertEqual(exc.args[0], gpgme.ERR_SOURCE_UNKNOWN)
-AssertionError: 7 != 0
-
-----------------------------------------------------------------------
-
-Patch copied from the Debian package pygpgme-0.3-1.2:
-
-https://sources.debian.net/src/pygpgme/0.3-1.2/debian/patches/0005-Fix-test-failures-with-pinentry.patch/
-
-From: "Dr. Tobias Quathamer" <toddy@debian.org>
-Date: Thu, 24 Nov 2016 12:20:54 +0100
-Subject: Fix test failures with pinentry
-
----
- tests/test_encrypt_decrypt.py | 5 +++--
- tests/test_passphrase.py | 2 ++
- 2 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/tests/test_encrypt_decrypt.py b/tests/test_encrypt_decrypt.py
-index 21ae83e..05707e1 100644
---- a/tests/test_encrypt_decrypt.py
-+++ b/tests/test_encrypt_decrypt.py
-@@ -132,6 +132,7 @@ class EncryptDecryptTestCase(GpgHomeTestCase):
- os.write(fd, b'Symmetric passphrase\n')
- ctx = gpgme.Context()
- ctx.armor = True
-+ ctx.pinentry_mode = gpgme.PINENTRY_MODE_LOOPBACK
- ctx.passphrase_cb = passphrase
- ctx.encrypt(None, 0, plaintext, ciphertext)
- self.assertTrue(
-@@ -182,8 +183,8 @@ class EncryptDecryptTestCase(GpgHomeTestCase):
- ctx.encrypt([recipient], gpgme.ENCRYPT_ALWAYS_TRUST,
- plaintext, ciphertext)
- except gpgme.GpgmeError as exc:
-- self.assertEqual(exc.args[0], gpgme.ERR_SOURCE_UNKNOWN)
-- self.assertEqual(exc.args[1], gpgme.ERR_GENERAL)
-+ self.assertEqual(exc.args[0], gpgme.ERR_SOURCE_GPGME)
-+ self.assertEqual(exc.args[1], gpgme.ERR_UNUSABLE_PUBKEY)
- else:
- self.fail('gpgme.GpgmeError not raised')
-
-diff --git a/tests/test_passphrase.py b/tests/test_passphrase.py
-index 35b3c59..05e6811 100644
---- a/tests/test_passphrase.py
-+++ b/tests/test_passphrase.py
-@@ -34,6 +34,7 @@ class PassphraseTestCase(GpgHomeTestCase):
- ctx = gpgme.Context()
- key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
- ctx.signers = [key]
-+ ctx.pinentry_mode = gpgme.PINENTRY_MODE_LOOPBACK
- plaintext = BytesIO(b'Hello World\n')
- signature = BytesIO()
-
-@@ -55,6 +56,7 @@ class PassphraseTestCase(GpgHomeTestCase):
- ctx = gpgme.Context()
- key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
- ctx.signers = [key]
-+ ctx.pinentry_mode = gpgme.PINENTRY_MODE_LOOPBACK
- ctx.passphrase_cb = self.passphrase_cb
- plaintext = BytesIO(b'Hello World\n')
- signature = BytesIO()