summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty10@gmail.com>2024-09-15 13:23:44 +0530
committerAndreas Enge <andreas@enge.fr>2024-09-21 09:38:48 +0200
commit9d75215a59629ab224154ef6b843043289291f81 (patch)
treeb21555cb21cd2b08e67383be81817bf37e25ca55 /gnu/packages/patches
parent2fb4ce5110c2e56d8390becef4c78df70cbee1ad (diff)
gnu: Add gemrb-0.9.3.
* gnu/packages/games.scm (gemrb-0.9.3): New variable. * gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Change-Id: Ic05eacf362f9a4ebfe88b1e0967e72e824c4f404 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch b/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch
new file mode 100644
index 0000000000..4e678f7fd4
--- /dev/null
+++ b/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch
@@ -0,0 +1,15 @@
+Add PATH_SUFFIXES to look inside the sub-directory `vlc` - the original statement
+only check for `vlc.h` inside the directory `include`, `bin`, etc.
+In Guix, however, `vlc.h` lies inside `/gnu/store/<hash>-vlc-x.y.z/include/vlc/vlc.h`
+
+--- a/cmake/modules/FindLIBVLC.cmake
++++ b/cmake/modules/FindLIBVLC.cmake
+@@ -29,7 +29,7 @@ FIND_PATH(LIBVLC_INCLUDE_DIR vlc/vlc.h
+ c:/msys/local/include
+ NO_DEFAULT_PATH
+ )
+-FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h)
++FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h PATH_SUFFIXES vlc)
+
+ #Put here path to custom location
+ #example: /home/user/vlc/lib etc..