summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-09-20 12:00:51 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-09-29 11:10:30 +0200
commit93ceb2d90165fa5e76f983f252f09bf97f3b17d8 (patch)
tree47c209972ec5d198a54d04e18e9e0e6a4cbd6f25 /gnu/packages/patches
parent786eb92c0f1ea8a22c9cf160440cd0722052e6f8 (diff)
gnu: rapidcheck: Fix pkg-config libs.
Using rapidcheck as a dependency in a project currently results in a linker error, because the pkg-config file is missing relevant linker flags. * gnu/packages/patches/rapidcheck-fix-libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/check.scm (rapidcheck)[patches]: Use it here.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/rapidcheck-fix-libs.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/rapidcheck-fix-libs.patch b/gnu/packages/patches/rapidcheck-fix-libs.patch
new file mode 100644
index 0000000000..5e5603116c
--- /dev/null
+++ b/gnu/packages/patches/rapidcheck-fix-libs.patch
@@ -0,0 +1,27 @@
+From c4f558b0990571759fdaf976eb35ee1eb0d934a0 Mon Sep 17 00:00:00 2001
+From: Robert Hensing <robert@roberthensing.nl>
+Date: Tue, 25 Jun 2024 20:57:41 +0200
+Subject: [PATCH] Add -lrapidcheck to pkg-config module
+
+This adds the library to rapidcheck.pc, so that it doesn't have
+to be specified manually in projects that consume it.
+
+The other modules don't need it because they have rapidcheck in
+their Requires field.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d55fdc51..046df2fd 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -128,7 +128,7 @@ set(PKG_CONFIG_DESCRIPTION_SUMMARY "C++ framework for property based testing ins
+ set(PKG_CONFIG_VERSION)
+ set(PKG_CONFIG_LIBDIR "\${prefix}/lib")
+ set(PKG_CONFIG_INCLUDEDIR "\${prefix}/include")
+-set(PKG_CONFIG_LIBS)
++set(PKG_CONFIG_LIBS "-L\${libdir} -lrapidcheck")
+ set(PKG_CONFIG_CFLAGS "-I\${includedir}")
+
+ configure_file(