summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2024-07-11 15:18:51 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:43 +0200
commit8a20f58420ff62cf2e9daeaf88d8ec1dfecb81b4 (patch)
tree009ace8cad65b8fbcdabec4adf88b5ce80ac6b70 /gnu/packages/patches
parent1c322552dd47dbefdd740e2a6750e310840e9244 (diff)
gnu: Boost: Fix a bug that breaks libetonyek.
This fixes <https://issues.guix.gnu.org/72040>. * gnu/packages/patches/boost-fix-duplicate-definitions-bug.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/boost.scm (boost)[source]: Use it. (boost-for-source-highlight): New variable, not using the patch. * gnu/packages/pretty-print.scm (source-highlight)[inputs]: Replace BOOST with BOOST-FOR-SOURCE-HIGHLIGHT. Change-Id: I5fbc9eb5000aefd7d3a14cc7a0482741032b5400
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/boost-fix-duplicate-definitions-bug.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/boost-fix-duplicate-definitions-bug.patch b/gnu/packages/patches/boost-fix-duplicate-definitions-bug.patch
new file mode 100644
index 0000000000..f2e3decedb
--- /dev/null
+++ b/gnu/packages/patches/boost-fix-duplicate-definitions-bug.patch
@@ -0,0 +1,38 @@
+Fix the build of libetonyek / libreoffice:
+
+https://issues.guix.gnu.org/72040
+
+Patch copied from upstream source repository:
+
+https://github.com/boostorg/phoenix/commit/8913607a3788cb82d48ed461ea59c919b7bad3df
+
+From 8913607a3788cb82d48ed461ea59c919b7bad3df Mon Sep 17 00:00:00 2001
+From: djowel <djowel@gmail.com>
+Date: Tue, 29 Aug 2023 14:32:41 +0800
+Subject: [PATCH] Disabled this for now, due to ODR violations $$$ Fix Me $$$
+
+---
+ include/boost/phoenix/stl/tuple.hpp | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/include/boost/phoenix/stl/tuple.hpp b/include/boost/phoenix/stl/tuple.hpp
+index fb9440d2..a2e42bec 100644
+--- a/include/boost/phoenix/stl/tuple.hpp
++++ b/include/boost/phoenix/stl/tuple.hpp
+@@ -106,6 +106,7 @@ namespace boost { namespace phoenix {
+ tuple_detail::idx_wrap<N>(), t);
+ }
+
++#if 0 // Disabled this for now due to ODR viaolations $$$ Fix Me $$$
+ // Make unpacked argument placeholders
+ namespace placeholders {
+ #define BOOST_PP_LOCAL_LIMITS (1, BOOST_PHOENIX_ARG_LIMIT)
+@@ -114,6 +115,8 @@ namespace boost { namespace phoenix {
+ boost::phoenix::get_<(N)-1>(boost::phoenix::placeholders::arg1);
+ #include BOOST_PP_LOCAL_ITERATE()
+ }
++#endif
++
+ }} // namespace boost::phoenix
+
+ #endif // C++ 14