summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-11 00:08:01 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:22 +0200
commit745177cea555c88d4c0c227ddca922e2eb76eedd (patch)
treefc7cada4ae4f42854a98879056fde9d8648cdb56 /gnu/packages/patches
parente7fdcffc73690c675477a3e48ecdb16f8fb5dd01 (diff)
gnu: gcc@7: Allow compilation with glibc 2.38.
* gnu/packages/patches/gcc-7-libsanitizer-fsconfig-command.patch: New file. * gnu/packages/gcc.scm (gcc-7)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: Ifa273b92573281c34d83e5fb8cd68734ef02c7fd
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gcc-7-libsanitizer-fsconfig-command.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/gcc-7-libsanitizer-fsconfig-command.patch b/gnu/packages/patches/gcc-7-libsanitizer-fsconfig-command.patch
new file mode 100644
index 00000000000..f203a5542d5
--- /dev/null
+++ b/gnu/packages/patches/gcc-7-libsanitizer-fsconfig-command.patch
@@ -0,0 +1,32 @@
+Avoid redefinition of ‘enum fsconfig_command’ and ‘struct mount_attr’ in
+libsanitizer with glibc 2.38.
+
+ https://github.com/draperlaboratory/hope-llvm-project/commit/d8daef856858ecbd19898c3e0de63e76221e2baa
+ https://github.com/llvm/llvm-project/issues/56421
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=113181
+
+--- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
++++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc
+@@ -73,7 +73,6 @@
+ #include <sys/vt.h>
+ #include <linux/cdrom.h>
+ #include <linux/fd.h>
+-#include <linux/fs.h>
+ #include <linux/hdreg.h>
+ #include <linux/input.h>
+ #include <linux/ioctl.h>
+@@ -876,10 +875,10 @@ unsigned struct_ElfW_Phdr_sz = sizeof(Elf_Phdr);
+ unsigned IOCTL_EVIOCGPROP = IOCTL_NOT_PRESENT;
+ unsigned IOCTL_EVIOCSKEYCODE_V2 = IOCTL_NOT_PRESENT;
+ #endif
+- unsigned IOCTL_FS_IOC_GETFLAGS = FS_IOC_GETFLAGS;
+- unsigned IOCTL_FS_IOC_GETVERSION = FS_IOC_GETVERSION;
+- unsigned IOCTL_FS_IOC_SETFLAGS = FS_IOC_SETFLAGS;
+- unsigned IOCTL_FS_IOC_SETVERSION = FS_IOC_SETVERSION;
++ unsigned IOCTL_FS_IOC_GETFLAGS = _IOR('f', 1, long);
++ unsigned IOCTL_FS_IOC_GETVERSION = _IOR('v', 1, long);
++ unsigned IOCTL_FS_IOC_SETFLAGS = _IOW('f', 2, long);
++ unsigned IOCTL_FS_IOC_SETVERSION = _IOW('v', 2, long);
+ unsigned IOCTL_GIO_CMAP = GIO_CMAP;
+ unsigned IOCTL_GIO_FONT = GIO_FONT;
+ unsigned IOCTL_GIO_UNIMAP = GIO_UNIMAP;