summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-15 23:03:37 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:26 +0200
commit4840707013ead04c661d5cd3fe78b871254af895 (patch)
tree45d93402a3855088e6841beb9a448c9dfd8bed82 /gnu/packages/patches
parenta0c17878166db205def211cdaa6e79712057f883 (diff)
gnu: ghc-9.2: Remove unneeded glibc 2.33 patch.
* gnu/packages/patches/ghc-9.2-glibc-2.33-link-order.patch: Remove. * gnu/local.mk (dist_patch_DATA): Unregister. * gnu/packages/haskell.scm (ghc-9.2): Remove patch use. Change-Id: I7d305dadb627f6af55e4a5faabfc835e4a78a05b
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ghc-9.2-glibc-2.33-link-order.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/patches/ghc-9.2-glibc-2.33-link-order.patch b/gnu/packages/patches/ghc-9.2-glibc-2.33-link-order.patch
deleted file mode 100644
index 5d4afa28c1..0000000000
--- a/gnu/packages/patches/ghc-9.2-glibc-2.33-link-order.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Slightly modified version of
-https://gitlab.haskell.org/ghc/ghc/-/issues/19029#note_447989, required
-for older, buggy glibc versions < 2.34.
-
-diff -Naur ghc-9.2.5/compiler/GHC/Linker/Unit.hs ghc-9.2.5.patched/compiler/GHC/Linker/Unit.hs
---- ghc-9.2.5/compiler/GHC/Linker/Unit.hs 2022-11-06 20:40:29.000000000 +0100
-+++ ghc-9.2.5.patched/compiler/GHC/Linker/Unit.hs 2023-01-15 14:52:57.511275338 +0100
-@@ -31,11 +31,26 @@
- ps <- mayThrowUnitErr $ preloadUnitsInfo' unit_env pkgs
- return (collectLinkOpts dflags ps)
-
-+fixOrderLinkOpts :: [String] -> [String]
-+fixOrderLinkOpts opts
-+ | have_bad_glibc_version -- glibc version strictly less than 2.34
-+ , let (before, rest) = break (== libc) opts
-+ , not (pthread `elem` before)
-+ , pthread `elem` rest -- optional if we know pthread is definitely present
-+ = before ++ pthread_and_deps ++ rest
-+ | otherwise
-+ = opts
-+ where
-+ pthread = "-lpthread"
-+ libc = "-lc"
-+ pthread_and_deps = [ "-lrt", pthread ] -- should depend on the environment
-+ have_bad_glibc_version = True
-+
- collectLinkOpts :: DynFlags -> [UnitInfo] -> ([String], [String], [String])
- collectLinkOpts dflags ps =
- (
- concatMap (map ("-l" ++) . unitHsLibs (ghcNameVersion dflags) (ways dflags)) ps,
-- concatMap (map ("-l" ++) . map ST.unpack . unitExtDepLibsSys) ps,
-+ fixOrderLinkOpts $ concatMap (map ("-l" ++) . map ST.unpack . unitExtDepLibsSys) ps,
- concatMap (map ST.unpack . unitLinkerOptions) ps
- )
-