summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-26 16:44:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-03 18:05:12 -0400
commit64e1797e213d69c62b5f33bc6d5fe5ae107209e6 (patch)
tree931fe960747048f3c01f9e4149b728871202a4b2 /gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch
parent4a301dae2bb33782933e2f112005b5d0ea813e62 (diff)
gnu: jami: Update to 20240325.0.
* gnu/packages/jami.scm (libjami): Update to 20240325.0. [make-flags]: Reinstate ut_media_player test. [phases]: Remove obsolete extend-scheduler-test-timeout phase. (jami): Update to 20240325.0. [source]: Remove jami-qml-tests-discovery patch. Add jami-qwindowkit and jami-tests-qtwebengine-ifdef-to-if patches. [configure-flags]: Add -DFETCHCONTENT_TRY_FIND_PACKAGE_MODE=ALWAYS. Replace -DENABLE_TESTS=ON with -DBUILD_TESTING=ON. [phases] <check>: Update comment for QML test suite. [native-inputs]: Add qthttpserver and qtwebsockets. [inputs]: Add qwindowkit. * gnu/packages/patches/jami-qml-tests-discovery.patch: Delete file. * gnu/packages/patches/jami-unbundle-dependencies.patch: Update patch. * gnu/packages/patches/jami-qwindowkit.patch: New file. * gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Update accordingly. Change-Id: I5d47bdfd2aabab5baff44db8436051a9890cba6d
Diffstat (limited to 'gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch')
-rw-r--r--gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch b/gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch
new file mode 100644
index 00000000000..63bfde6af0e
--- /dev/null
+++ b/gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch
@@ -0,0 +1,26 @@
+Upstream-status: https://lists.gnu.org/archive/html/jami/2024-03/msg00005.html
+
+Fix macro value checking.
+
+diff --git a/tests/qml/main.cpp b/tests/qml/main.cpp
+index 2fbecebe..8cb3de69 100644
+--- a/tests/qml/main.cpp
++++ b/tests/qml/main.cpp
+@@ -35,7 +35,7 @@
+ #include <QtQuickTest/quicktest.h>
+ #include <QSignalSpy>
+
+-#ifdef WITH_WEBENGINE
++#if WITH_WEBENGINE
+ #include <QtWebEngineCore>
+ #include <QtWebEngineQuick>
+ #endif
+@@ -192,7 +192,7 @@ main(int argc, char** argv)
+ // Allow the user to enable fatal warnings for certain tests.
+ Utils::remove_argument(argv, argc, "--failonwarn", [&]() { qputenv("QT_FATAL_WARNINGS", "1"); });
+
+-#ifdef WITH_WEBENGINE
++#if WITH_WEBENGINE
+ QtWebEngineQuick::initialize();
+ #endif
+ QTEST_SET_MAIN_SOURCE_PATH