summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gobject-introspection-cc.patch
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
committerAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
commit4ac0d6444d4edf38edc7c07331cf76deb4a506bc (patch)
tree5264c9c87172b8f0015823b0ee891d3672ac291a /gnu/packages/patches/gobject-introspection-cc.patch
parentd074e2f99130782e8eb7fa44c79c01db6c86f77d (diff)
parent7bde30e18de3e8cd7e4156ea5bb0d9439b6c12d7 (diff)
Merge branch 'master' into core-updates.
Diffstat (limited to 'gnu/packages/patches/gobject-introspection-cc.patch')
-rw-r--r--gnu/packages/patches/gobject-introspection-cc.patch25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/patches/gobject-introspection-cc.patch b/gnu/packages/patches/gobject-introspection-cc.patch
index 38b919a746d..d9cacf4ca74 100644
--- a/gnu/packages/patches/gobject-introspection-cc.patch
+++ b/gnu/packages/patches/gobject-introspection-cc.patch
@@ -1,14 +1,11 @@
---- a/giscanner/sourcescanner.py 2013-12-15 23:03:54.002937000 +0100
-+++ b/giscanner/sourcescanner.py 2013-12-15 23:04:50.322937000 +0100
-@@ -277,6 +277,11 @@
- defines = ['__GI_SCANNER__']
- undefs = []
- cpp_args = os.environ.get('CC', 'cc').split() # support CC="ccache gcc"
-+ if (cpp_args == ['cc'] and
-+ not any(map(lambda x: os.access(os.path.join(x, 'cc'), os.X_OK),
-+ os.environ.get('PATH').split(':')))):
-+ cpp_args = ['GUIX_GCC_PATH']
-+
- if 'cl' in cpp_args:
- # The Microsoft compiler/preprocessor (cl) does not accept
- # source input from stdin (the '-' flag), so we need
+Use gcc as the default C compiler if CC is not set.
+
+
+--- gobject-introspection-1.44.0.orig/giscanner/__init__.py 2014-08-04 22:37:07.000000000 +0800
++++ gobject-introspection-1.44.0/giscanner/__init__.py 2015-04-20 17:30:26.507697234 +0800
+@@ -22,3 +22,5 @@
+ builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
+ if builddir is not None:
+ __path__.append(os.path.join(builddir, 'giscanner'))
++if not 'CC' in os.environ:
++ os.environ['CC'] = 'gcc'