summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-11-17 21:05:15 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2025-01-12 12:14:33 +0800
commit58c9e87426a681f4d8b943968dbfce3325d956f2 (patch)
treef88c4b9829dd7b9191872073e95dc5c080c00483 /gnu/packages/music.scm
parent3badd6aafccd142544b95ab45e22871c4508f224 (diff)
gnu: sonivox-eas: Update to 1.5.1.
* gnu/packages/music.scm (sonivox-eas): Update to 1.5.1. [build-system]: Switch to qt-build-system. [arguments]<#:qtbase>: Use qtbase. [inputs]: Remove qtbase-5. Add qtwayland and sonivox. [license]: Remove asl2.0. Change-Id: If65a359fcc70254f69edda318a72ea957572fb3f Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d03cb3fd95..11e4284539 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5926,7 +5926,7 @@ real time GM synthesizer.")
(define-public sonivox-eas
(package
(name "sonivox-eas")
- (version "1.3.0")
+ (version "1.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5935,11 +5935,13 @@ real time GM synthesizer.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1ygmlrsdzxii2dvj6id2ai3xv3klw2x67ip5rcp823jzczl0wpjd"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; there are no tests
+ "1y67bi2vcwb1avwz18i41q85cmqx9svwx4q3kpmh951l49s9k8vz"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase
+ #:tests? #f)) ; there are no tests
(inputs
- (list alsa-lib drumstick pulseaudio qtbase-5))
+ (list alsa-lib drumstick pulseaudio qtwayland sonivox))
(native-inputs
(list pkg-config))
(home-page "https://github.com/pedrolcl/Linux-SonivoxEas")
@@ -5947,9 +5949,7 @@ real time GM synthesizer.")
(description "This project is a real time General MIDI synthesizer based
on the Sonivox EAS Synthesizer by Google. It does not need external
soundfonts, using embedded samples instead.")
- ;; Sonivox is released under the ASL2.0; the rest of the code is under
- ;; GPLv2+.
- (license (list license:gpl2+ license:asl2.0))))
+ (license license:gpl2+)))
(define-public whysynth
(package