summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-11-17 21:05:13 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2025-01-12 12:14:30 +0800
commit1a8db74afc91170698397dd16251e9122159cc9a (patch)
treea4c55c8912103345d944e11c3554a51314133399 /gnu/packages/music.scm
parentcf6783ed65c87a1a62f62dc4952ff65704dbaf11 (diff)
gnu: Add sonivox.
* gnu/packages/music.scm (sonivox): New variable. Change-Id: I50d98ed353264d52d1341baff9dabd5b4e2eecfa Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 8c0f1bb48b..6c854ace94 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5885,6 +5885,35 @@ your favorite sampled sounds and bashing away on a MIDI controller.")
the electronic or dubstep genre.")
(license license:gpl3+))))
+(define-public sonivox
+ (package
+ (name "sonivox")
+ (version "3.6.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pedrolcl/sonivox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zn9v4lxjpnpdlpnv2px8ch3z0xagmqlvff5pd39pss3mxfp32g0"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ (if (%current-target-system)
+ #~(list "-DBUILD_TESTING=OFF")
+ #~(list "-DBUILD_TESTING=ON"))))
+ (native-inputs
+ (list googletest))
+ (home-page "https://github.com/pedrolcl/sonivox")
+ (synopsis "Fork of the AOSP platform_external_sonivox")
+ (description "This project is a fork of the Android Open Source Project
+@code{platform_external_sonivox}. It is a Wave Table synthesizer, using
+embedded samples. It also supports external DLS soundfont files. It is also a
+real time GM synthesizer.")
+ (license license:asl2.0)))
+
(define-public sonivox-eas
(package
(name "sonivox-eas")