summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/messaging.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index cc4aeed24e..dd94292f69 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1177,12 +1177,16 @@ simultaneously and therefore appear under the same nickname on IRC.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests? (invoke "python" "-m" "unittest" "-v")))))))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
(inputs
(list glib
glib-networking
libsoup-minimal
python-gssapi
python-idna
+ python-packaging
python-precis-i18n
python-pygobject))
(synopsis "Non-blocking XMPP Module")