summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLars Bilke <lars.bilke@ufz.de>2025-01-02 14:17:12 +0100
committerAndreas Enge <andreas@enge.fr>2025-01-22 11:03:32 +0100
commit343073b4cbdfc5898508edb78578b6684cb7e058 (patch)
tree874fc6f7190e1935b9ee46ad42b1f640b4db666b /gnu/packages/maths.scm
parent7080aaf08102ec4c9c976582d6adfa0c14e6c640 (diff)
gnu: Add exprtk.
* gnu/packages/maths.scm (exprtk): New variable. Change-Id: I25e5a37cfd72b4b47dedc36916781b6ac355501e Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ed9c7bfa0e..d3c48f8006 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10898,3 +10898,25 @@ groups. Documentation is available on
(home-page "http://www-math.univ-poitiers.fr/~maavl/LiE/")
;; <http://www-math.univ-poitiers.fr/~maavl/LiE/> says LGPL.
(license license:lgpl3+)))
+
+(define-public exprtk
+ (package
+ (name "exprtk")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ArashPartow/exprtk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pszh11w29nc256qhil51g3635n06ncf0ihg7g4h86jrhqsk7183"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("exprtk.hpp" "include/"))))
+ (synopsis "C++ Mathematical Expression Parsing And Evaluation Library")
+ (description "ExprTk is a C++ headers only library for mathematical
+expression parsing and evaluation.")
+ (home-page "https://www.partow.net/programming/exprtk/index.html")
+ (license license:expat)))