summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/linux.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0fc2c4428af..f71830067e9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4662,7 +4662,7 @@ time.")
(string-append
(assoc-ref inputs "kernel-headers") "/include/linux"))))))))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/gvalkov/python-evdev")
(synopsis "Bindings to the Linux input handling subsystem")
(description
@@ -5298,6 +5298,7 @@ SMBus access.")
(string-append "-L" #$(this-package-input "i2c-tools")
"/lib"))))))))
(inputs (list i2c-tools))
+ (native-inputs (list python-setuptools python-wheel))
(synopsis "I2C/SMBus access for Python")
(description "This package provides a Python library to access
@acronym{I2C, Inter-Integrated Circuit} and @acronym{SMBus, System