summaryrefslogtreecommitdiff
path: root/gnu/packages/librewolf.scm
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty10@gmail.com>2024-08-08 23:58:44 +0530
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-11 02:00:00 +0200
commit5d1c3bad5c629f3fa588155e3afbf2b1cc9e8603 (patch)
tree42ff9bc268914096def0f505a0e684c4397a9ecc /gnu/packages/librewolf.scm
parent936928fe38946a7496273e636ca8888914d100a9 (diff)
gnu: librewolf: Use distinct WM Class.
Make desktop environments properly render the icon and not conflate LibreWolf with other browsers with the "Navigator" class. A similar fix to IceCat was pushed as commit be1d05c10766a979dd0720b677889ed950d3b895. * gnu/packages/librewolf.scm (librewolf)[arguments]: Set both the MOZ_APP_REMOTINGNAME environment variable and librewolf.desktop's StartupWMClass to "LibreWolf". Change-Id: I3e117f99ee25321fe3a40ad67450460971579d71
Diffstat (limited to 'gnu/packages/librewolf.scm')
-rw-r--r--gnu/packages/librewolf.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/librewolf.scm b/gnu/packages/librewolf.scm
index 3e46477724..45fbb84e4f 100644
--- a/gnu/packages/librewolf.scm
+++ b/gnu/packages/librewolf.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2023 Tomas Volf <wolf@wolfsden.cz>
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -413,6 +414,7 @@
(setenv "CC" "clang")
(setenv "CXX" "clang++")
(setenv "MOZ_NOSPAM" "1")
+ (setenv "MOZ_APP_REMOTINGNAME" "LibreWolf")
(setenv "MOZ_APP_NAME" "librewolf")
(setenv "MOZBUILD_STATE_PATH"
@@ -626,8 +628,7 @@
(("-NewPrivateWindow")
"-new-private-window")
(("StartupNotify=true")
- "StartupNotify=true
-StartupWMClass=Navigator"))
+ "StartupNotify=true\nStartupWMClass=LibreWolf"))
(copy-file desktop-file "librewolf.desktop")
(install-file "librewolf.desktop" applications))))
(add-after 'install-desktop-entry 'install-icons