summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 15:41:17 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:38 +0000
commit5748c809e01f4cb86ed09076dfd6a359021d9e9c (patch)
treefe16c6794041bb8b6c557f60706fd3a5754b23c9 /gnu/packages/jupyter.scm
parenta1504cde345d2a5c04c2cf639892ee655dfddc9a (diff)
gnu: Add python-hatch-jupyter-builder.
* gnu/packages/jupyter.scm (python-hatch-jupyter-builder): New variable. Change-Id: I5bdf00a95dd6260eb5f6066a77394054bcec0ca4
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 2298e87ccd..c485e68b9c 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -326,6 +326,33 @@ Jupyter Python packages that require a pre-build step that may include
JavaScript build steps.")
(license license:bsd-3)))
+(define-public python-hatch-jupyter-builder
+ (package
+ (name "python-hatch-jupyter-builder")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hatch_jupyter_builder" version))
+ (sha256
+ (base32 "1baqk80c5ddhksh73l48mb59vvaaa2ldrs65k6vldii4s6c829vr"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Don't attempt to build anything, because we don't have network access
+ ;; anyway.
+ (list #:test-flags '(list "-k" "not test_hatch_build")))
+ (propagated-inputs (list python-hatchling))
+ (native-inputs (list python-pytest
+ python-pytest-cov
+ python-pytest-mock
+ python-tomli
+ python-twine))
+ (home-page "https://github.com/jupyterlab/hatch-jupyter-builder")
+ (synopsis "Hatch plugin to help build Jupyter packages")
+ (description
+ "This package provides a hatch plugin to help build Jupyter packages.")
+ (license license:bsd-3)))
+
(define-public python-jupyter-server
(package
(name "python-jupyter-server")