summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-07 22:26:32 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:41 +0000
commit3e9af5f2082cf78e77528a49e8cc574195afb8e2 (patch)
tree890f7000f50e017c243edd63e61361dc41bfb154 /gnu/packages/jupyter.scm
parentd87b326d1d436650f167c1635775ba2dbd415914 (diff)
gnu: Add python-jupyter-server-terminals.
* gnu/packages/jupyter.scm (python-jupyter-server-terminals): New variable. Change-Id: I83445e6ac40e21e6e284f1764090f113f56921bf
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index b8f416117d..71dea7021e 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -576,6 +576,29 @@ JavaScript build steps.")
endpoints—to Jupyter web applications.")
(license license:expat)))
+(define-public python-jupyter-server-terminals
+ (package
+ (name "python-jupyter-server-terminals")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter_server_terminals" version))
+ (sha256
+ (base32 "0sajiadhwncrr0inzzkrs7l1xc6jmw9b5zfw1v79l3i2cx8jkq2s"))))
+ (build-system pyproject-build-system)
+ ;; The tests require python-jupyter-server, but python-jupyter-server
+ ;; needs this package.
+ (arguments (list #:tests? #false))
+ (propagated-inputs (list python-terminado))
+ (native-inputs
+ (list python-hatchling))
+ (home-page "https://pypi.org/project/jupyter-server-terminals/")
+ (synopsis "Jupyter Server extension providing terminals")
+ (description
+ "This package provides a Jupyter Server extension providing terminals.")
+ (license license:bsd-3)))
+
(define-public python-jupyterlab-widgets
(package
(name "python-jupyterlab-widgets")