summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-10 11:53:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-30 15:06:35 +0000
commit868a3a541885c8dc901017a7a1db8caaf97e8812 (patch)
treea22cd8feea04988f275390cbd3c55ebb0b14d637 /gnu/packages/julia-xyz.scm
parent69e1aa218678d1932296cfdc6980e4bf71aee39b (diff)
gnu: Add julia-commonsolve.
* gnu/packages/julia-xyz.scm (julia-commonsolve): New variable. Change-Id: If73125bcfe53b26c818fedd14bd8ddbbb863e887
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 81315a91a5..03621a94c7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1265,6 +1265,29 @@ they are points in a normed vector space.")
focusing mostly (as of now) on enumerative combinatorics and permutations.")
(license license:expat)))
+(define-public julia-commonsolve
+ (package
+ (name "julia-commonsolve")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SciML/CommonSolve.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1w05fp02g5cmqzqp96hcpriwjpqx61sl481rj92gf4y4xpinmdf5"))))
+ (build-system julia-build-system)
+ (home-page "https://docs.sciml.ai/CommonSolve/stable")
+ (synopsis "Common solve function for scientific machine learning")
+ (description
+ "CommonSolve.jl provides @code{solve}, @code{init}, @code{solve!}, and
+@code{step!} commands. By using the same definition, solver libraries from
+other completely different ecosystems can extend the functions and thus not
+clash with SciML if both ecosystems export the solve command.")
+ (license license:expat)))
+
(define-public julia-commonsubexpressions
(package
(name "julia-commonsubexpressions")