summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-19 14:00:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:51 +0000
commit9ff0a399438b11a5a4e248565df3512343896e1c (patch)
tree1565cb6abb41c774c9195f9b17fcd3ffb41552f9 /gnu/packages/irc.scm
parent922d0170818b6f9ba55b6202825f689b645419eb (diff)
gnu: build/go: Apply default 'fix-embed-files phase.
These changes remove redundant phases where files, requiring to be embed during build or check phases, are copied to the build directory as proposed in <https://issues.guix.gnu.org/73299>. * gnu/packages/backup.scm (restic-rest-server) [arguments]: <#:phases>: Remove 'fix-embed-files phase. * gnu/packages/configuration-management.scm (chezmoi): Likewise. * gnu/packages/packages/golang-build.scm (go-github-com-golang-protobuf): Likewise. * gnu/packages/golang-web.scm (go-github-com-go-openapi-loads, go-github-com-go-openapi-runtime, go-github-com-golang-groupcache): Likewise. * gnu/packages/golang-xyz.scm (go-github-com-dgraph-io-badger): Likewise. * gnu/packages/golang.scm (go-github-com-ssgelm-cookiejarparser): Likewise. * gnu/packages/ipfs.scm (go-github-com-ipfs-go-ds-badger, go-github-com-libp2p-go-libp2p, kubo): Likewise. * gnu/packages/irc.scm (soju): Likewise. * gnu/packages/networking.scm (nebula): Likewise. * gnu/packages/prometheus.scm (go-github-com-nbrownus-go-metrics-prometheus, go-github-com-prometheus-client-golang, go-github-com-prometheus-common, go-github-com-prometheus-common-sigv4, go-github-com-prometheus-exporter-toolkit, go-github-com-prometheus-statsd-exporter): Likewise * gnu/packages/version-control.scm (git-lfs): Likewise. * gnu/packages/web.scm (miniflux): Likewise. * gnu/packages/golang-crypto.scm (go-filippo-io-age): [arguments]: <#:phases>: Remove 'copy-input-to-vendor-direcotyr and 'remove-vendor-directory phases. * gnu/packages/golang-web.scm (go-github-com-go-openapi-analysis, go-github-com-go-openapi-analysis, go-github-com-go-openapi-validate): Likewise. * gnu/packages/golang.scm (go-github-com-charmbracelet-glamour): Likewise. * gnu/packages/textutils.scm (vale): Likewise. Change-Id: Ic2ec01c8caf86f3ae69d7a1812c1e0b78a549e91
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index e75432673e..51bd43869e 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -1160,24 +1160,6 @@ what.")
#:import-path "codeberg.org/emersion/soju"
#:phases
#~(modify-phases %standard-phases
- ;; TODO: Implement it in go-build-system.
- ;;
- ;; This happens due to Golang can't determine the valid directory of
- ;; the module of embed file which is symlinked during setup
- ;; environment phase, but easy resolved after coping file from the
- ;; store to the build directory of the current package, see details
- ;; in Golang source:
- ;;
- ;; - URL: <https://github.com/golang/go/blob/>
- ;; - commit: 82c14346d89ec0eeca114f9ca0e88516b2cda454
- ;; - file: src/cmd/go/internal/load/pkg.go#L2059
- (add-after 'unpack 'fix-embed-files
- (lambda _
- (for-each (lambda (file)
- (let ((file-store-path (readlink file)))
- (delete-file file)
- (copy-recursively file-store-path file)))
- (find-files "src" ".*(editions_defaults.binpb)$"))))
(add-after 'unpack 'adjust-makefile
(lambda* (#:key import-path #:allow-other-keys)
(with-directory-excursion (string-append "src/" import-path)