summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 09:25:32 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:48 +0100
commit8f70fb90a24096499ecd7077ff9a29497bb4e6cc (patch)
tree20568d8fa73f3351f9594705edc9cc97d26a2b97 /gnu/packages/ipfs.scm
parent1edca36f334b081a10bfb30d043c951c9bb6ab18 (diff)
gnu: packages/golang: Set default go version to 1.21.
Golang versions 1.17 (02 Aug 2022), 1.18 (01 Feb 2023), 1.19 (06 Sep 2023) and 1.20 (06 Feb 2024) are EOL <https://endoflife.date/go>. These changes set preferable default version to the minimal currently maintained one e.g. 1.21 * gnu/packages/golang.scm (go): Set default to go-1.21, add annotation for the future maintenance. Remove field <#:go> setting Golang version to go-1.18, go-1.19, 1.20 and 1.21: * gnu/packages/admin.scm * gnu/packages/configuration-management.scm * gnu/packages/databases.scm * gnu/packages/disk.scm * gnu/packages/education.scm * gnu/packages/file-systems.scm * gnu/packages/finance.scm * gnu/packages/golang-check.scm * gnu/packages/golang-crypto.scm * gnu/packages/golang-web.scm * gnu/packages/golang-xyz.scm * gnu/packages/golang.scm * gnu/packages/high-availability.scm * gnu/packages/ipfs.scm * gnu/packages/irc.scm * gnu/packages/messaging.scm * gnu/packages/networking.scm * gnu/packages/syncthing.scm * gnu/packages/textutils.scm * gnu/packages/time.scm * gnu/packages/version-control.scm * gnu/packages/video.scm Change-Id: Ieba6a5d7a18423f838d14c02ad55a2ba9c8559eb
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index daf68903c2..078d50c5d8 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -56,7 +56,6 @@
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-block-format"))
(propagated-inputs
(list go-github-com-multiformats-go-multihash
@@ -88,7 +87,6 @@ corresponding to the block.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-cid"))
(propagated-inputs
(list go-github-com-multiformats-go-multihash
@@ -117,7 +115,6 @@ used in @code{go-ipfs} and related packages to refer to a typed hunk of data.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-cidutil"))
(propagated-inputs
(list go-github-com-ipfs-go-cid
@@ -237,7 +234,6 @@ throughout its lifetime.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-detect-race"))
(home-page "https://github.com/ipfs/go-detect-race")
(synopsis "Detect if compiled with race")
@@ -262,7 +258,6 @@ throughout its lifetime.")
go-github-com-multiformats-go-multihash))
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-ipfs-util"))
(home-page "https://github.com/ipfs/go-ipfs-util")
(synopsis "Common utilities used by @code{go-ipfs} and related packages")
@@ -286,7 +281,6 @@ throughout its lifetime.")
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-ipld-cbor"))
(propagated-inputs
(list go-github-com-ipfs-go-block-format
@@ -360,7 +354,6 @@ IPLD graph as detailed below. Objects are demonstrated here using both
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-ipld-format"))
(propagated-inputs
(list go-github-com-multiformats-go-multihash
@@ -389,7 +382,6 @@ order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-fore
(build-system go-build-system)
(arguments
(list
- #:go go-1.21
#:unpack-path "github.com/ipld/go-ipld-prime/"
#:import-path "github.com/ipld/go-ipld-prime/"
#:phases
@@ -489,7 +481,6 @@ basic operations on IPLD objects (traversals, etc).")
go-go-uber-org-zap))
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-log/v2"))
(home-page "https://github.com/ipfs/go-log")
(synopsis "Logging library used by @code{go-ipfs}")
@@ -520,7 +511,6 @@ their levels to be controlled individually.")
go-go-uber-org-zap))
(arguments
(list
- #:go go-1.21
#:import-path "github.com/ipfs/go-log"))))
(define-public go-github-com-whyrusleeping-cbor-gen
@@ -753,7 +743,6 @@ written in Go.")
(list
#:unpack-path "github.com/ipfs/kubo"
#:import-path "github.com/ipfs/kubo/cmd/ipfs"
- #:go go-1.21
#:phases
#~(modify-phases %standard-phases
;; https://github.com/ipfs/kubo/blob/master/docs/command-completion.md