summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:20 +0200
commit6399cf4240f7b009e6fc24773c5f8bd7d7b83621 (patch)
treeae71bb2909fe28a0f28bbf0ed2308319877e5639 /gnu/packages/haskell-xyz.scm
parent8f6461b0d635ed95fd5f0415bf6e4fcdd446f3d7 (diff)
gnu: Add ghc-brick.
* gnu/packages/haskell-xyz.scm (ghc-brick): New variable. Change-Id: I52fbfa27422a6aacca65d0e8ed5ffa3ab335cc67
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 659171d3d57..960136e8725 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15872,6 +15872,39 @@ purposes. See the
[README](https://github.com/aaronallen8455/breakpoint#breakpoint) for details.")
(license license:expat)))
+(define-public ghc-brick
+ (package
+ (name "ghc-brick")
+ (version "2.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "brick" version))
+ (sha256
+ (base32 "160np0bz1mcfkp077yc936i026s3zv1czn8lj3k3qr6scldavw35"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "brick")))
+ (inputs (list ghc-vty-6
+ ghc-vty-crossplatform
+ ghc-bimap
+ ghc-data-clist
+ ghc-microlens
+ ghc-microlens-th
+ ghc-microlens-mtl
+ ghc-config-ini
+ ghc-vector
+ ghc-text-zipper
+ ghc-unix-compat-7
+ ghc-word-wrap
+ ghc-random))
+ (native-inputs (list ghc-quickcheck))
+ (home-page "https://github.com/jtdaugherty/brick/")
+ (synopsis "Declarative terminal user interface library")
+ (description
+ "Brick helps you write @dfn{terminal user interfaces} (TUIs). You write
+an event handler and a drawing function and the library does the rest.")
+ (license license:bsd-3)))
+
(define-public ghc-githash
(package
(name "ghc-githash")