summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:09 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:48 +0000
commitfa2a30fa5add5644c65e5a2cba5973648379a95a (patch)
tree71dc5418e2782d7b8e1ac1db5be950abaf9be1c9 /gnu/packages/haskell-xyz.scm
parentd8611090b941e5c3afb10416db91c99ef15c5dbb (diff)
gnu: Add ghc-language-python.
* gnu/packages/haskell-xyz.scm (ghc-language-python): New variable. Change-Id: I29bcdedf155486673e01b3b6af71a2aa81455ef6 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3915bf29b0e..7024d54ff23 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6455,6 +6455,31 @@ beginning with @code{test} (for a test framework) or all functions beginning
with @code{wc} (for a web service).")
(license license:bsd-3)))
+(define-public ghc-language-python
+ (package
+ (name "ghc-language-python")
+ (version "0.5.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "language-python" version))
+ (sha256
+ (base32 "1mf3czvnh9582klv0c9g7pcn1wx4qjwpvhv8la6afaifv6y5lki2"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision ("2"
+ "024fn653gmxw4ndmqvg1d3lwmxbvrlllc9iw2zw0c3nkcgcv39sg")))
+ (native-inputs (list ghc-alex ghc-happy))
+ (inputs (list ghc-monads-tf ghc-utf8-string))
+ (home-page "http://github.com/bjpop/language-python")
+ (synopsis "Parse and pretty print Python code in Haskell")
+ (description
+ "@code{language-python} is a Haskell library for lexical analysis,
+parsing and pretty printing Python code. It supports versions 2.x and 3.x of
+Python.")
+ (license license:bsd-3)
+ (properties '((upstream-name . "language-python")))))
+
(define-public ghc-lens
(package
(name "ghc-lens")