summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2025-01-05 22:20:33 +0100
committerVagrant Cascadian <vagrant@debian.org>2025-01-05 15:38:52 -0800
commitbc58a33be0d61403ecf37dfeb33db06a8828d4cc (patch)
treee8bce16d91bafa09dde6b36e011a1cb5b047d9d2 /gnu/packages/haskell-xyz.scm
parent8df34932ba0bf4a2cdfbcab88b956c2ee61052df (diff)
gnu: Fix whitespace issues in Haskell package descriptions.
This mainly addresses `double-space after sentence end period' and `trailing white space' issues. * gnu/packages/haskell-check.scm (ghc-tasty-expected-failure, ghc-quickcheck-classes-base, ghc-doctest-lib): Fix description. * gnu/packages/haskell-web.scm (ghc-hxt-unicode): Fix description. * gnu/packages/haskell-xyz.scm (ghc-fsnotify, ghc-gtk2hs-buildtools, ghc-operational, ghc-commonmark, ghc-template-haskell): Fix description. Change-Id: I5a71ad41bbddf1ad4c880dacc0a53992a38c71ad Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f8d68243ce7..0a58ee4d244 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4404,7 +4404,7 @@ definition of @code{Monad}.")
(home-page "https://github.com/haskell-fswatch/hfsnotify")
(synopsis "Cross platform library for file change notification")
(description "Cross platform library for file creation, modification, and
-deletion notification. This library builds upon existing libraries for platform
+deletion notification. This library builds upon existing libraries for platform
specific Windows, Mac, and Linux file system event notification.")
(license license:bsd-3)))
@@ -4745,10 +4745,10 @@ monoid with invertibility.")
(synopsis "Tools to build the Gtk2Hs suite of user interface libraries")
(description
"This package provides a set of helper programs necessary to build the
-Gtk2Hs suite of libraries. These tools include a modified c2hs binding tool
+Gtk2Hs suite of libraries. These tools include a modified c2hs binding tool
that is used to generate FFI declarations, a tool to build a type hierarchy
that mirrors the C type hierarchy of GObjects found in glib, and a generator
-for signal declarations that are used to call back from C to Haskell. These
+for signal declarations that are used to call back from C to Haskell. These
tools are not needed to actually run Gtk2Hs programs.")
(license license:gpl2)))
@@ -8302,7 +8302,7 @@ found at runtime, a userError is thrown.")
"Implementation of difficult monads made easy with operational semantics")
(description
"This library makes it easy to implement monads with tricky control
-flow. This is useful for: writing web applications in a sequential style,
+flow. This is useful for: writing web applications in a sequential style,
programming games with a uniform interface for human and AI players and easy
replay capababilities, implementing fast parser monads, designing monadic
DSLs, etc.")
@@ -15129,7 +15129,7 @@ ones.
Accurate information about source positions is available for all block and
inline elements. Thus the library can be used to create an accurate syntax
-highlighter or an editor with live preview. The parser has been designed for
+highlighter or an editor with live preview. The parser has been designed for
robust performance even in pathological cases that tend to cause stack
overflows or exponential slowdowns in other parsers, with parsing speed that
varies linearly with input length.")
@@ -15243,7 +15243,7 @@ platform independent way.")
(synopsis "Support library for Template Haskell")
(description
"This package provides modules containing facilities for manipulating
-Haskell source code using Template Haskell. See
+Haskell source code using Template Haskell. See
@uref{http://www.haskell.org/haskellwiki/Template_Haskell} for more
information.")
(license license:bsd-3)))