summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/graph.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 02033c25b3..46e556ecc0 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -250,8 +250,12 @@ more.")
var (format #f "[~s]~%"
(string-append igraph "/lib")))))))))))
(inputs (list igraph))
- (propagated-inputs (list python-texttable))
- (native-inputs (list python-pytest))
+ (propagated-inputs
+ (list python-texttable))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://igraph.org/python/")
(synopsis "Python bindings for the igraph network analysis library"))))
@@ -419,11 +423,12 @@ algorithm for community detection in large networks.")
(("self.use_pkgconfig = False")
"self.use_pkgconfig = True")))))))
(inputs (list igraph))
- (propagated-inputs (list python-igraph))
+ (propagated-inputs (list python-igraph python-setuptools))
(native-inputs
(list pkg-config
python-ddt
- python-setuptools-scm))
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/vtraag/louvain")
(synopsis "Community detection in large networks")
(description