summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:39:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-14 23:41:00 +0100
commit3948cbe9aa405bfeb2c0d6b88573cd26c312ee02 (patch)
tree5dfda46450d277374fee860df483e3781273a2cc /gnu/packages/golang.scm
parent3b3f3891c68f8247190643a02f7fa86a580e8f34 (diff)
gnu: go-github-com-pelletier-go-toml: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-pelletier-go-toml, go-github-com-pelletier-go-toml-v2): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I76dae5d71ae761af6d7f23ce55286996c55a5d50
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm47
1 files changed, 0 insertions, 47 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4c6b04cd620..77d9a4f0657 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3573,53 +3573,6 @@ updating files, like @command{tail -f}.")
(description "Java properties scanner for Go")
(license license:bsd-2)))
-(define-public go-github-com-pelletier-go-toml
- (package
- (name "go-github-com-pelletier-go-toml")
- (version "1.9.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pelletier/go-toml")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1wypjrr1axkrkzp4n5gvams94f2sd7dq1pdpd2i35sgpdz6r2m6g"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/pelletier/go-toml"))
- (propagated-inputs
- (list go-github-com-burntsushi-toml
- go-github-com-davecgh-go-spew
- go-gopkg-in-yaml-v2))
- (home-page "https://github.com/pelletier/go-toml")
- (synopsis "Go library for the TOML configuration language")
- (description "Go library for the TOML configuration language")
- (license license:expat)))
-
-(define-public go-github-com-pelletier-go-toml-v2
- (package
- (inherit go-github-com-pelletier-go-toml)
- (name "go-github-com-pelletier-go-toml-v2")
- (version "2.2.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pelletier/go-toml")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0gimgz33yxmvj0nmy56yy7zq4ay8j55ir8pfzmgwga7npgpzspk7"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/pelletier/go-toml/v2"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (propagated-inputs '())))
-
(define-public go-github-com-subosito-gotenv
(package
(name "go-github-com-subosito-gotenv")