summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-17 12:05:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:46 +0100
commit95cf183452348612b4024c54877d9b419d9a4852 (patch)
treea0c6ad55f6939e2f0a7fa7f3ada7216fc218e457 /gnu/packages/golang-xyz.scm
parent66abf5f2f05c1b1b7f30fe0239292b01a411c2e6 (diff)
gnu: Add go-github-com-oklog-run.
* gnu/packages/golang-xyz.scm (go-github-com-oklog-run): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: If0a0f1cb274ed10e991001079ff152dbe31c8ce4
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7e674ae0ecb..d58b1434c24 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5049,6 +5049,32 @@ queue.")
NSQ protocol @url{https://nsq.io/}.")
(license license:expat)))
+(define-public go-github-com-oklog-run
+ (package
+ (name "go-github-com-oklog-run")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oklog/run")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0r55p3kgdkgw55i33lqvvvl60mjp92mhd1170m980sw98z9150jk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/oklog/run"))
+ (home-page "https://github.com/oklog/run")
+ (synopsis "Universal mechanism to manage goroutine lifecycles")
+ (description
+ "@code{run.Group} is a universal mechanism to manage goroutine
+lifecycles, written to manage component lifecycles in @code{func main} for OK
+Log. It's useful in any circumstance where you need to orchestrate multiple
+goroutines as a unit whole.")
+ (license license:asl2.0)))
+
(define-public go-github-com-op-go-logging
(package
(name "go-github-com-op-go-logging")