summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-24 19:46:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:48 +0100
commitf24fb6f7c67a6df5a0209dda20e85b6dc8ddd744 (patch)
tree5a06bcc33bfc7b2807986897a5a10262bc513885 /gnu/packages/golang-web.scm
parent82c63dfe31cc0fc918b11cd3f0f5fa18d0e534f4 (diff)
gnu: Add go-github-com-go-openapi-spec.
* gnu/packages/golang-web.scm (go-github-com-go-openapi-spec): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I4fa578345ffa7ad550926b37489f1a0c5a827fb9
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 1b75fb9406d..58ef149541d 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1428,6 +1428,38 @@ prototyped in @url{https://github.com/xeipuuv/gojsonpointer}.")
prototyped in @url{https://github.com/xeipuuv/gojsonreference}.")
(license license:asl2.0)))
+(define-public go-github-com-go-openapi-spec
+ (package
+ (name "go-github-com-go-openapi-spec")
+ (version "0.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-openapi/spec")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07qp7gakrjwznbxg1w5ww8j0ky407s9rmyyrpwv5rsp8yw6qimjc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/go-openapi/spec"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-go-openapi-jsonpointer
+ go-github-com-go-openapi-jsonreference
+ go-github-com-go-openapi-swag
+ go-gopkg-in-yaml-v3))
+ (home-page "https://github.com/go-openapi/spec")
+ (synopsis "OpenAPI specification object model")
+ (description
+ "This package implements functionality to marshal and unmarshal
+@url{https://swagger.io/,Swagger} API specifications into a Golang object
+model.")
+ (license license:asl2.0)))
+
(define-public go-github-com-go-openapi-swag
(package
(name "go-github-com-go-openapi-swag")