summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:37:07 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commitc98ff7dcff7456ff95e2cb8e4b678e7728e74e76 (patch)
treec093b4fbfa0d957288f358fe19b73830bb37dee4 /gnu/packages/golang-web.scm
parentfaea1bad5f5f6b1097aab54d57b620a3ce9d3ae3 (diff)
gnu: Add go-github-com-pascaldekloe-goe.
* gnu/packages/golang-web.scm (go-github-com-pascaldekloe-goe): New variable. Change-Id: Idd1de1f2d2e5aab8c6e257706fefa1960bce53ab
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index feb4e6c978..a14d05e4eb 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -4123,6 +4123,38 @@ used to read GeoLite2 and GeoIP2 databases, @code{geoip2} provides a
higher-level API for doing so.")
(license license:isc)))
+(define-public go-github-com-pascaldekloe-goe
+ (package
+ (name "go-github-com-pascaldekloe-goe")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pascaldekloe/goe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mszfjcc29b6nvw3hs8w33iy6zx6ih5v2jlard0dsrgkpvsx5c81"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pascaldekloe/goe"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Replace when go-build-system supports nested path.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (home-page "https://github.com/pascaldekloe/goe")
+ (synopsis "Enterprise tooling for Golang")
+ (description
+ "Common enterprise features for the Go programming language.")
+ (license license:cc0)))
+
(define-public go-github-com-pion-datachannel
(package
(name "go-github-com-pion-datachannel")