summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 22:38:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:54 +0000
commit3e063c821e205d4166b91bad101a88f0cb8e4021 (patch)
treece1153d8b86df62c74744e253407351f5c7831b7 /gnu/packages/golang-web.scm
parentcf3fe8f507765498169750a0832b7d65a3bffe1e (diff)
gnu: Add go-github-com-pkg-browser.
* gnu/packages/golang-web.scm (go-github-com-pkg-browser): New variable. Change-Id: I02b0c499dbde8dfd9862df61def348fcec381fb9
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e4c0054539..6e47aef039 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -4860,6 +4860,32 @@ are supported. @acronym{TLV, tag-length-value} parsers extensions comming with
this library support AWS, Azure and GCP.")
(license license:asl2.0)))
+(define-public go-github-com-pkg-browser
+ (package
+ (name "go-github-com-pkg-browser")
+ (version "0.0.0-20240102092130-5ac0b6a4141c")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/browser")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05m0baqy1grd42by3vgih55473fa98cz2psyakbmf0swg8f949pn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pkg/browser"))
+ (propagated-inputs (list go-golang-org-x-sys))
+ (home-page "https://github.com/pkg/browser")
+ (synopsis "Helpers to open files, readers, and URLs in a browser window")
+ (description
+ "Package browser provides helpers to open files, readers, and urls in a
+browser window. The choice of which browser is started is entirely client
+dependant.")
+ (license license:bsd-2)))
+
(define-public go-github-com-pkg-sftp
(package
(name "go-github-com-pkg-sftp")