summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-17 22:15:58 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:39:00 +0100
commitb371174536ede66e90b239dd46ebc9bb45d80543 (patch)
tree66e05f7ea4ba1c6c979f15e3b6983a32c3331c81 /gnu/packages/gnupg.scm
parentde5239b6753f776334bcbc9364c77722ffaeedcc (diff)
gnu: libgpg-error: Support the 64bit Hurd.
* gnu/packages/patches/libgpg-error-hurd64.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gnupg.scm (libgpg-error)[arguments]: Use it when building for the 64bit Hurd. Change-Id: Icabb7cd7bb5bcc771ccee5b8a7f57f52b9b58183
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 3f55ccaf5b..1ed06642d7 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2021 Nikita Domnitskii <nikita@domnitskii.me>
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
@@ -144,9 +144,25 @@
;; configuration, as this is not correct for
;; all architectures.
(_ #t)))
- (#t #t)))))))
+ (#t #t)))))
+ #$@(if (target-hurd64?)
+ #~((add-after 'unpack 'apply-hurd64-patch
+ (lambda _
+ (let ((patch
+ #$(local-file
+ (search-patch
+ "libgpg-error-hurd64.patch"))))
+ (invoke "patch" "--force" "-p1" "-i" patch)))))
+ #~())))
((system-hurd?)
- #~((add-after 'unpack 'skip-tests
+ #~((add-after 'unpack 'apply-hurd64-patch
+ (lambda _
+ (let ((patch
+ #$(local-file
+ (search-patch
+ "libgpg-error-hurd64.patch"))))
+ (invoke "patch" "--force" "-p1" "-i" patch))))
+ (add-after 'unpack 'skip-tests
(lambda _
(substitute* "tests/t-syserror.c"
(("(^| )main *\\(.*" all)