summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2025-01-01 22:41:10 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2025-01-12 12:14:33 +0800
commit1f1b652e77acaad961834a6b8b11852d8104fe0a (patch)
tree7587dd47c181087cc4eb750eaf7048a74ef32f5b /gnu/packages/gnupg.scm
parent699cf001dcf0804980ce7ab3efe5c21176c42626 (diff)
gnu: Add pinentry-qt5.
* gnu/packages/gnupg.scm (pinentry-qt5): New variable. Change-Id: Ia70f00002305ab8e1bd6b0edb0ee6ee84007bf8c Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 4f1914d99d..ad7b1e2e9e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -944,6 +944,15 @@ software.")))
"Pinentry provides a console and a Qt GUI that allows users to enter a
passphrase when @code{gpg} is run and needs it.")))
+(define-public pinentry-qt5
+ (package
+ (inherit pinentry-qt)
+ (name "pinentry-qt5")
+ (inputs
+ (modify-inputs (package-inputs pinentry-qt)
+ (replace "qtbase" qtbase-5)
+ (replace "qtwayland" qtwayland-5)))))
+
(define-public pinentry-efl
(package
(inherit pinentry-tty)