summaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-08 20:56:57 +0200
committerMarius Bakke <marius@gnu.org>2022-09-08 20:56:57 +0200
commitfa894b3f4db835bd0bb52b32c7ec412e72b7e03a (patch)
tree2e06c29a1272ca0fad677184706ee95052993009 /gnu/packages/gnunet.scm
parent6cfb2e6270b2759fb98a0de665235bcbb9b9eccf (diff)
parente8bded2de72c17317d7799b699a724086f92ed7b (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm54
1 files changed, 35 insertions, 19 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index a0f902e534..b477fee537 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages file)
#:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
@@ -349,29 +350,35 @@ services.")
(define-public gnunet-scheme
(package
(name "gnunet-scheme")
- (version "0.2")
+ (version "0.3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://git.gnunet.org/git/gnunet-scheme.git")
- (commit (string-append "v" version))))
+ ;; Go three commits beyond the v0.3 tag, as these three
+ ;; commits work-around
+ ;; <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=49623>.
+ (commit "f5dc44e66373c29f1c84ea89d8080939a8dfbfd2")))
(file-name (git-file-name name version))
(sha256
(base32
- "0a11n58m346vs2khns2hfnxv8lbscf8aaqzhmq0d7nwdpn808nrp"))
+ "0kvqbqijfyp3fhsqjyzwd7b3cm5khwv557wq196mv6rx47aaivgd"))
(modules '((guix build utils)))
- ;; XXX: Work-around
- ;; <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=49623>,
- ;; this can be removed once Guile > 3.0.7 is released.
- (snippet '(substitute* '("gnu/gnunet/config/parser.scm"
- "tests/config-parser.scm")
- (("#\\{\\$\\{\\}\\}#") "#{${;};}#")
- (("#\\{\\$\\{:-\\}\\}#") "#{${;:-};}#")
- (("#\\{\\$\\{\\}\\}# #\\{\\$\\{:-\\}\\}#")
- "#{$\\x7b;\\x7d;}# #{$\\x7b;:-\\x7d;}#")
- (("'#\\{\\$\\{\\}\\}# '#\\{\\$\\{:-\\}\\}#")
- "'#{$\\x7b;\\x7d;}# '#{$\\x7b;:-\\x7d;}#")))))
+ (snippet
+ ;; Unbundle dependencies. TODO: build-aux/test-driver.scm
+ ;; is bundled too, but it's not yet automatically copied by
+ ;; autoreconf -i.
+ #~(delete-file "build-aux/config.rpath"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; For reproducibility, do not insert real timestamps in the PDF.
+ (add-after 'unpack 'reproducible-timestamp
+ (lambda _
+ (substitute* "Makefile.am"
+ (("\\$\\(TEXMACS_CONVERT\\)")
+ "faketime -m -f '1970-01-01 00:00:00' $(TEXMACS_CONVERT)")))))))
(inputs (list guile-3.0)) ;for pkg-config
(propagated-inputs (list guile-bytestructures guile-gcrypt guile-pfds
guile-fibers-1.1))
@@ -382,6 +389,7 @@ services.")
guile-gcrypt
guile-pfds
guile-fibers-1.1
+ libfaketime
automake
autoconf
pkg-config
@@ -390,11 +398,19 @@ services.")
guile-quickcheck)) ;for tests
(synopsis "Guile implementation of GNUnet client libraries")
(description
- "This package provides Guile modules for connecting to the NSE (network
-size estimation) and DHT (distributed hash table) services of GNUnet. It also
-has infrastructure for writing new GNUnet services and connecting to them and
-can be used from multi-threaded environments. It is not to be confused with
-@code{guile-gnunet} -- @code{guile-gnunet} supports a different set of services.")
+ "This package provides Guile modules for connecting to various
+GNUnet services. It also has infrastructure for writing new GNUnet services and
+connecting to them and can be used from multi-threaded environments. It is not
+to be confused with @code{guile-gnunet} -- @code{guile-gnunet} supports a different
+set of services.
+
+The following services are supported:
+
+@itemize
+@item NSE (network size estimation)
+@item DHT (distributed hash table)
+@item CADET (secure end-to-end communication between arbitrary peers)
+@end itemize")
;; Most code is licensed as AGPL and a few modules are licensed as LGPL
;; or GPL. Documentation is licensed as GFDL.
(license (list license:agpl3+ license:gpl3+ license:fdl1.3+ license:lgpl3+))