summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-12-05 16:14:56 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2025-01-05 20:28:17 -0500
commite11df9879534db0475044f3cf54a5ffd27e00f39 (patch)
tree78ca2dfdc22936ea19366b04610fcd45df8852d5 /gnu/packages/gl.scm
parentb7767304327cf3965a59cc4ff85805bb852c9d2e (diff)
gnu: mesa: Update to 24.3.1.
* gnu/packages/gl.scm (mesa): Update to 24.3.1. [arguments]: Add 'set-home-directory phase (build tries to use a shader cache, though this without it won't fail to build). Change-Id: I1fd7d1fe20109ccdd7386a82ecf7d415999c262a
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e1dfca7ca81..418970547ee 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -303,7 +303,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "24.2.5")
+ (version "24.3.1")
(source
(origin
(method url-fetch)
@@ -313,7 +313,7 @@ also known as DXTn or DXTC) for Mesa.")
"mesa-" version ".tar.xz")))
(sha256
(base32
- "0vyrkmy8j5bygddi2bsssj9g1rrcg4vfhvw0bjxsbmif4km0ngbk"))))
+ "1bs310dw9jjzvvchszmb3jakqb5268ssp83ba9ybrrcw8h05jycw"))))
(build-system meson-build-system)
(propagated-inputs
;; The following are in the Requires.private field of gl.pc.
@@ -545,6 +545,9 @@ directory = ~a
(from-crates-io 'rust-proc-macro2-1)
(from-crates-io 'rust-paste-1))))))))
#~())
+ (add-after 'unpack 'set-home-directory
+ ;; Build tries to use a shader cache (non-fatal error).
+ (lambda _ (setenv "HOME" "/tmp")))
(add-before 'configure 'fix-dlopen-libnames
(lambda* (#:key inputs #:allow-other-keys)
(let ((out #$output))