summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-14 19:46:36 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2025-01-05 20:28:19 -0500
commitce7443bb674be73d206bcb8e23aad30f4af20c51 (patch)
tree7a78609d91acf9406ceb1ba36f99e3f801727b99 /gnu/packages/gl.scm
parente02075f37dc494b312c09ed6106d85eb134c0a41 (diff)
gnu: mesa: Build asahi vulkan driver on aarch64-linux.
* gnu/packages/gl.scm (mesa)[arguments]: Adjust the configure-flags to also build the asahi vulkan driver when building for aarch64. Change-Id: I65320d254734b93c2d0a0891cdf329e7b3ff0c12
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 418970547ee..b3e70bcc6ba 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -411,7 +411,7 @@ panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
'("-Dvulkan-drivers=intel,intel_hasvk,amd,swrast"))
((target-aarch64?)
;; This differs from "auto" which only includes swrast and intel
- '("-Dvulkan-drivers=freedreno,amd,broadcom,swrast"))
+ '("-Dvulkan-drivers=freedreno,amd,broadcom,swrast,asahi"))
(else
'("-Dvulkan-drivers=auto")))