summaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:41 +0000
commitfdc0fefd46a45b70784a4e3f8900cbe593426a9e (patch)
tree13c3736334bde1c3ec75d67f4e430396e23eed3f /gnu/packages/geo.scm
parentca945f7c35bbc5d05a6ad7e5baa15f79e0fd0ecc (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index a9a9e1c945..50decdd14a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -359,7 +359,9 @@ subdivisions.")
python-numpy
python-pytest
python-scikit-build
- python-setuptools-scm))
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(inputs (list h3))
(home-page "https://uber.github.io/h3-py")
(synopsis "Python bindings for H3")
@@ -1012,7 +1014,7 @@ pyproj, Rtree, and Shapely.")
(list python-fiona python-packaging python-pandas python-pyproj
python-shapely))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://geopandas.org")
(synopsis "Geographic pandas extensions")
(description "The goal of GeoPandas is to make working with
@@ -1141,7 +1143,7 @@ during conversion.")
python-pandas
python-requests
python-shapely))
- (native-inputs (list python-hatchling python-pytest))
+ (native-inputs (list python-hatchling python-pytest python-setuptools python-wheel))
(home-page "https://github.com/gboeing/osmnx")
(synopsis
"Retrieve, model, analyze, and visualize OpenStreetMap street networks")
@@ -2109,7 +2111,7 @@ from multiple records.")
(string-append "\"" libspatialindex
"/lib/libspatialindex_c.so\"")))))))))
(native-inputs
- (list python-numpy python-pytest python-wheel))
+ (list python-numpy python-pytest python-setuptools python-wheel))
(inputs
(list libspatialindex))
(home-page "https://github.com/Toblerity/rtree")